Search Results

All Results 6926
Sort By
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Expired Articles Are Still Showing up in the Live Site After Publishing
Issue If you schedule an article to be expired on a certain date and time, after publishing the article to the live site you may find the article is not expired. There are a few possible reasons for this behavior described with their resolutions below. Resolution Scenario 1: The default...
Known Issue: Modification Dates of All the Versions of a Web Content are Updated After Expiring it
This article documents a known issue related to the modified dates of Web Content versions. Issue Expiring a Web Content when System Setting Expire All Article Versions Enabled is checked, will update the modified dates of all Web Content versions to the current time. Resolution STATUS:...
Elasticsearch Connector Configuration: Reference
Please be aware that the page you are viewing has been machine translated from Japanese into English and may contain some translation errors. If you observe any issues with the translation, please contact us. Elasticsearch is the default search engine in Liferay DXP 7.1.The Liferay...
Known Issue: Drag and Drop Pages Under Link to URL Type Pages is Working, But the Configuration is Not Saved
Issue When you drag and drop pages under Link to URL type pages, it appears as if the structure changes, but after refreshing the browser, the page order is not saved. Resolution This is a known issue, and the reason that this does not work is because Link to URL page types cannot be...
Back Navigation Breaks Dialogs in iOS Safari
Summary There is a known issue with iOS Safari while using history.pushState(), which is an API that Liferay uses. Issues outside of Liferay can be found at: Stack Overflow: Alert, Confirm, and Prompt Not Working After Using History API on Safari, iOS Github: Navigating Back Breaks...
Site Roles Are Incorrectly Assigned or Lost When They Are Selected from Different Pages
This article documents a bug in the search container with any list of selectable items. It was discovered that site administrators could not assign a Site Role if that Site Role is not listed on the first page. Roles that were listed on the second pages were subsequently deselected when...
Remove the Ability to Add JavaScript in the Control Panel's Site Pages
Issue Disable the ability to add JavaScript to pages on DXP 7.0 and thus prevent malicious code injections. Environment  DXP 7.0 Fix Pack 60+ This functionality was introduced in DXP 7.0 Fix Pack 60 Resolution Install DXP 7.0 Fix Pack 60 or higher. In the portal-ext.properties, add the...
How to Translate Forms for Localisation in DXP 7.0
Issue Can I translate Forms in Liferay DXP 7.0 for localisation of our different language sites? We have found the translation function for Web Content, but cannot find it for Forms. Environment DXP 7.0, 7.1 Resolution Translation of Forms feature is not available for DXP 7.0.  The...
Help Center Statuses and Priority Levels
There are a few different types of statuses within the workflow of a support ticket in Help Center.  Below is an overview of the 3 categories of statuses you will encounter on a ticket. System Status When you create a support ticket in Help Center, you will be asked for details on your...
Limitations in SASS Preprocessing in Theme Generation
This article documents the limitations for resolving potential startup performance issues when deploying custom themes and portlets in DXP 7.0. Note: the limitations are found only in 7.0. When using DXP 7.x, some developers noticed that after deploying their custom theme or portlet, the...
DXP 7.0 Fix Pack 70: Compatibility changes and deployment notes for Connector to Elasticsearch 6 and Solr 5 Search Engine
Liferay DXP 7.0 Fix Pack 70 and SP10 includes the fixes for LPS-79348, LPS-78857 and LPS-80931. Part of the changes (namely in LPS-78857) new APIs were added to the com.liferay.portal.search.api module which all Liferay search engine connectors must implement to function properly and to...
Liferay Developer Studio 3.5.0 Release Highlights
Liferay Developer Studio provides an all-in-one, integrated development environment based on Eclipse for developers to build plugins for the Liferay Digital Experience Platform. Liferay Developer Studio is an Eclipse product that includes the Liferay IDE plugins, additional enterprise...
Unable to Connect to External Datasources After Applying DXP 7.1 FP3+
This is no longer an issue with 7.1 FP10+. Recently, LPS-85683 was implemented in Liferay DXP 7.1's core infrastructure and can be deployed by applying DXP 7.1 Fix Pack 3.  LPS-85683 detailed a project where Liferay core engineers refactored the spring extender to allow for subsequent...
Known Issues: Liferay Commerce
This article documents a list of known issues that exist in Liferay Commerce. Commerce 2.2.0 Commerce 2.1.3 Commerce 2.1.2 Commerce 2.1.1 Commerce 2.1.0 Commerce 2.0.7 Commerce 2.0.0 Commerce 1.1.4 Commerce 1.1.1 Commerce 1.1.0 Resolution Liferay Commerce contains the following known...
Known Issue: Instance Activation Service Disabled When Regenerating LCS Token
This article documents a known issue causing the instance activation service to be disabled by default when an LCS token is regenerated. The issue occurs for LCS tokens that have been created before January 17th 2019. If LCS Admins regenerate the LCS token with Instance Activation...
"Inaccessible Object" exception while using JDK11
Description If you are using JDK11 in a Linux environment and have the LCS 5.0.0 client deployed, you may receive the following error on startup: ERROR [LCS Worker 2][BaseScheduledTask:92] java.lang.reflect.InaccessibleObjectException: Unable to make public long...
Troubleshooting Adaptive Media Issues
This article is designed to help with troubleshooting Adaptive Media issues. Adaptive Media detects the device capabilities of the visitor and automatically delivers an appropriate scaled and optimized version of your stored media. Q1. "What happens if the adaptive media process gets...
"Illegal Access" Warning while using JDK 11
Description If you are using JDK11, you may receive the following error: WARNING: An illegal reflective access operation has occurred WARNING: Illegal reflective access by com.liferay.petra.reflect.ReflectionUtil...
Differences Between Adaptive Media Settings and Browser Dev Tools
This reference article is for customers who design and troubleshoot their web pages using Liferay DXP's Adaptive Media functionality. Frequently, content creators inspect their web pages using tools built into their browser for various reasons. They want to see that all their web...
LCS boot delegation property on WebSphere breaks the embedded Elasticsearch 6.5 in DXP 7.1 FP5
This article documents a known issue with the embedded Elasticsearch 6.5 Connector. Elasticsearch 6.5 is now the default embedded ES connector in DXP 7.1 after applying DXP 7.1 Fix Pack 5. It was discovered that after applying FP5, there is a startup error in platforms deployed on...

Showing 5,941 to 5,960 of 8,814 entries.