Search Results

All Results 6925
Sort By
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Cannot start up server after applying a new patch
Issue After installing a new fix pack / hotfix, the portal is not starting up, even though the temporary folders have been deleted. 06-Dec-2021 13:15:32.439 SEVERE [main] org.apache.catalina.core.StandardContext.listenerStart Exception sending context initialized event to listener...
Liferay fails to manage unique session and displays the mismatched data of the users
Issue Liferay fails to manage unique sessions and displays the mismatched data of the users when using the below code ThemeDisplay td = (ThemeDisplay) renderRequest.getAttribute(WebKeys.THEME_DISPLAY); User user = td.getUser(); String clientId = user.getScreenName().toUpperCase();...
Service "com.liferay.portal.kernel.messaging.DestinationFactory" is unavailable
Issue What does this error mean? When it will occur? 2021-07-21 00: 02: 06.207 ERROR [ServerService Thread Pool - 111] [ServiceProxyFactory: 109] Service "com.liferay.portal.kernel.messaging.DestinationFactory" is unavailable in 60000 milliseconds while setting field "...
Errors when executing upgrade process for com.liferay.exportimport.service
Issue The ExportImport Service failed during the upgrade from Liferay 6.2 to DXP 7.2: ERROR - Failed upgrade process for module com.liferay.exportimport.service com.liferay.portal.kernel.upgrade.UpgradeException: com.liferay.portal.kernel.exception.SystemException:...
How apply changes to Tomcat's server.xml file in Liferay PaaS
Note: please note that Liferay has renamed its Liferay Experience Could offerings to Liferay SaaS (formerly LXC) and Liferay PaaS (formerly LXC-SM). Issue I need to make some changes in Tomcat's server.xml file, but don't know how to do it in a Cloud environment. Environment Liferay PaaS...
The jgroupsping entries not getting deleted from table in Kubernetes environment
Issue In case of using Kubernetes, you might encounter a problem in your cluster using JDBC_PING, as the entries from the jgroupsping table related to the shutdown pods are not getting deleted. Environment DXP 7.3+ Kubernetes Resolution Set the following property:...
Upgrading from Fix Pack 1 to Fix Pack 2 in Liferay DXP 7.3, a NoSuchGroupException occurs
Issue When upgrading from Fix Pack 1 to Fix Pack 2, issues with the control panel options arise, such as being unable to use the page building option and having no portlets visible on the home page. The console errors seen during server startup are listed below. ERROR...
com.microsoft.sqlserver.jdbc.SQLServerException: The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption
Issue The server is down with the below exception. What does this error mean? ERROR [https-jsse-nio-8443-exec-144] [JDBCExceptionReporter: 234] The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: "Connection reset...
Application performance comparison between Unicast and Multicast configurations
Issue As per the business-specific requirement, modified the configurations by changing from default multicast with unicast clustering. While doing so, how the application performance will be impacted between Unicast and Multicast configurations? Environment Liferay 6.2  Resolution There...
Create custom notification module
Issue Unable to get notification over UI even after adding entry in usernotificationevent table through UserNotificationEvent API. Environment Liferay DXP 7.2 Resolution Even after adding entry in usernotificationentry, in order to interpret the notification event and determine whether...
Using JSONFactoryUtil.looseDeserialize method deserilizes to HashMap instead of my class.
Issue We have a WAR portlet that uses JSONFactoryUtil.looseDeserialize method. Also, our class is defined as whitelisted. See following: json.deserialization.whitelist.class.names=\ com.liferay.portal.kernel.cal.DayAndPosition,\ com.liferay.portal.kernel.cal.Duration,\...
Getting com.mysql.cj.jdbc.exceptions.CommunicationsException on server startup
Issue User gets below error on server startup/restart: ERROR [main][DialectDetector:147] com.mysql.cj.jdbc.exceptions.CommunicationsException: Communications link failure__The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from...
NullPointerException in service builder methods after upgrade to DXP 7.3
Issue After upgrading the portal to DXP 7.3, the following stack trace in some custom modules is reported: Caused by: java.lang.NullPointerException at com.liferay.portal.cache.internal.dao.orm.FinderCacheImpl._getArguments(FinderCacheImpl.java:466) at...
"Your request failed to complete" error is displayed on the user interface but there is no more information about it
Issue If there is an unexpected error, sometimes a "Your request failed to complete" error is displayed on the user interface, but no additional information is given. How can I get more information on this error? Environment Any Liferay DXP version Resolution In order to get more...
How can I manually force the generation of document thumbnails?
Issue It is necessary to regenerate all thumbnails of the documents in documents and media. After executing "Reset preview and thumbnail file for Documents and Media" in the server administration section, the thumbnails are deleted, but they are not regenerated until the thumbnail is...
Multiple Spring MVC Portlets names are not displayed in Add Widget menu when added in the same WAR file
Issue When creating custom widgets, if multiple widgets are deployed within the same war file, the individual names of the widgets are not seen in the Add Widget menu within Liferay Instead, each widget shares the same name Environment Liferay DXP 7.3 Resolution This occurs if a widget...
Known Issue [Resolved]: Staging publications in the Global site fail due to duplicate categories after upgrade to 7.3 or 7.4
Issue After upgrading our 7.0 bundle (where we had some categories in the Global site used for various assets) to 7.3, the vocabularies look to be duplicated in the post-upgrade environment (one list that cannot be edited/deleted), and new staging publishing events in the Global site are...
Fetching the web contents with the "Accept-Language" header returns different languages
Issue Fetching the web contents using the headless API with the "Accept-Language" header returns the selected language variation if there is a translation for it, but otherwise, it returns the default language version. curl -X GET...
Known Issue: "PermissionChecker not initialized" errors are observed and no pages are rendered following upgrade to 7.3
Issue After upgrading from 7.0 to 7.3, when we start up our bundle for the first time the site does not render any pages (other than to show "powered by" on the home page) and the following error can be observed in the logs: Caused by: java.lang.RuntimeException:...
How to connect to API Rest using Digest Auth in 7.1
Issue It's not possible to accces to an endpoint in 7.1 when using Digest Auth using the same configuration as used in higher versions (for our example we'll use 7.3). For the reproduction steps we'll use: the same endpoint used in How To Invoke A Service, namely...

Showing 7,501 to 7,520 of 8,813 entries.