Search Results

All Results 6922
ソート
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Sometimes the "This portlet could not be found. Please redeploy it or remove it from the page." error is displayed instead the real portlet
Issue Sometimes after starting the Liferay server, the: This portlet could not be found. Please redeploy it or remove it from the page. error is displayed instead the real portlet Environment Any Liferay DXP version Resolution You should check the Liferay log file for any startup error...
Non service builder generated services are not retrieved by ServiceLocator in freemarker template
Issue By default, is not allowed to retrieve non-service builder generated services by ServiceLocator in freemarker template, getting this error: 2022-08-25 08:30:38.427 WARN [http-nio-8080-exec-10][ServiceLocator:42] Denied access to service...
Encountering 'UT005023: Exception handling request to /: java.lang.ArrayIndexOutOfBoundsException: 0' errors when starting JBoss EAP server
Issue The server cannot be started due to the following error after installing DXP 7.4 on the JBoss EAP server: ERROR [io.undertow.request] (default task-1) UT005023: Exception handling request to /: java.lang.ArrayIndexOutOfBoundsException: 0 at...
Deploy Liferay DXP 7.3 as a Windows Service in a Liferay Bundle
Issue How to deploy a Liferay DXP 7.3 bundle as a Windows Service Environment Windows OS Resolution  Download from Apache Tomcat windows binaries. Copy the missing files from the bin folder in the downloaded binaries to the bundle folder $TOMCAT_HOME/bin. Use service.bat to install the...
How to interpretate order in event actions like logout.events.post
Issue Imposing an order to event actions that can be defined either in portal-ext.properties or as an OSGi component (using key property) is somehow tricky. Environment Configuring an event action that needs to be executed in a specific order. Examples of events are: login.events.pre,...
Can't change user's password: Passwords may not be changed under the current password policy.
Issue As an administrator, when trying to change a user's password the message "Error: Passwords may not be changed under the current password policy" is shown. Under certain circumstances the message is NOT shown, but the passwords cannot be changed regardless.   Environment Liferay DXP...
Unable to add 'related products' via headless API
Issue Steps to reproduce: 1. Start Liferay DXP 7.3 2. Create a site using a 'minium site template'. 3. Invoke the below API using CURL: curl --location --request PATCH 'http://localhost:8080/o/headless-commerce-admin-catalog//v1.0/products/by-externalReferenceCode/MIN93027' \ --header...
The first FreeMarker Engine entry in the list cannot be removed by a user interface control
Issue FreeMarker Engine interface has 2 variables: 'Restricted classes' and 'Restricted variables'. Open user interface: Control Panel > System Settings> Template Engines > FreeMarker Engine (in DXP 7.4). There is no UI control to remove the first item in the list. Unlike item number 2...
"No primary key column found for XXXXX" on upgrade process
Issue During the upgrade process you could see this errors in your upgrade logs: 2021-09-30 14:25:57.235 INFO [main][UpgradeProcess:115] Failed upgrade process com.liferay.portal.upgrade.PortalUpgradeProcess in 8114 ms com.liferay.portal.kernel.upgrade.UpgradeException:...
Empty drop down icon is visible in calendar portlet for guest users
Issue Steps to reproduce: 1. Start Liferay DXP 7.3 2. Drop the 'Calendar Widget' on a page. 3. Configure the Calendar portlet to disable the RSS subscription. 4. Now, access the page as a guest user. Expected Behavior: The dropdown menu icon must not be visible. Actual Behavior: When...
Log level of jsonwebservice
Please be aware that the page you are viewing has been machine translated from Japanese into English and may contain some translation errors. If you observe any issues with the translation, please contact us. event In DXP 7.3, the logs thrown could be adjusted by adjusting the log level...
Using the default locale property/environment variable won't change the language
Issue Setting the default language in the portal-ext.properties, with the property company.default.locale=nl_NL or as an environment variable LIFERAY_COMPANY_PERIOD_DEFAULT_PERIOD_LOCALE=nl_NL  doesn't change the language even after restarting the bundle and deleting the cache....
Dockbar is temporarily unavailable workaround
Issue Suddenly, while navigating or performing an action, an error like "Dockbar is temporarily unavailable" appears. Resolution Usually this error, if it doesn't happen consistently, is a consequence of performance issues. So, how should you proceed? Check the log for relevant errors....
User wants to setup a scheduler job, but only with one specific node within the cluster.
Issue User wants a scheduler job to run on only one specific node of the cluster. Environment Liferay DXP 7.1 Liferay DXP 7.2 Liferay DXP 7.3 Liferay DXP 7.4 Resolution A cron job can be disabled in a certain node by setting below property in nodes' portal-ext.properties file:...
Invalid character found in the HTTP protocol
Issue The tomcat server is fully started, however for some reason, it's shutting down after some minutes with the below error INFO [http-nio-8080-exec-7] org.apache.coyote.http11.Http11Processor.service Error parsing HTTP request header Note: further occurrences of HTTP request parsing...
Scheduled job not failing over when master node goes down
Issue You might encounter an issue with your custom scheduled jobs where they are not getting planned if the master node goes down and the new master is elected Environment Liferay DXP 7.0+ Resolution Make sure that you use unregister() instead of unschedule() in the deactivate() method...
Show Number of Requests in Redirection > 404 URLs Tab
Issue When I navigate to Site Administration > Redirection > 404 URLs, all URLs show 0 requests Environment DXP 7.3 Resolution For the 404 URLs Requests counter to track the number of views, View Count must be enabled in Control Panel > System Settings > Infrastructure > View Count....
Scheduled publications are always scheduled using the server time zone on 7.1
Issue Staging publishes scheduled for the future automatically defaults to server time zone, which does not allow for much flexibility unless one manually re-schedules them. Environment Liferay DXP 7.1 Resolution The observed behavior is a known issue/bug and is addressed via LPS-116633...
How to redirect a user's browser refresh request to the logout page
Issue Users should redirect to the Logout page whenever they refresh the page (CTRL+R) or attempt to reload the page from anywhere in the application. Environment Liferay DXP 7.2 Resolution There is no portal property or out-of-the-box feature that would help here to achieve this...
How to clear only a specific OSGi module directory from osgi/state/
Issue Is it possible to clear only the data from a specific module in osgi/state/ instead of clearing the whole directory? Environment Liferay DXP 7.0+ Resolution Imagine we want to clear the data of module com.example. Use the Gogo Shell to find the OSGi bundle id: g! lb -s com.example...

該当件数: 8,810 件中 7,381 - 7,400