Search Results

All Results 6925
ソート
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Old auditing data taking up database space
Issue Are there any alternative methods to manage audit data? Environment DXP 7.3   DXP 7.2 Resolution As an alternative to saving all of the logging data into the database, instead, we may choose to save it to a JSON or CSV file. The same disk space requirements remain, but it can...
Audit modules is not starting after upgrade
Issue After upgrading from Liferay Portal 6.2 to Liferay 7.2. The following audit module error is appearing. 2020-11-05 10:07:14.615 INFO [Start Level: Equinox Container: 69cf58a7-c02f-4bb9-a8ed-60445fa81573][UpgradeProcess:93] Upgrading...
Troubleshooting java.lang.NoClassDefFoundError and java.lang.ClassNotFoundException Optional Dependency Errors
Issue When starting up Liferay, the following errors are observed: java.lang.NoClassDefFoundError or java.lang.ClassNotFoundException. Environment Liferay DXP with deployed custom modules including optional dependencies. Resolution Review the deployed MANIFEST.MF inside the module or the...
Layout permissions lost upgrading from 6.2 to 7.2
Issue After the upgrade from 6.2 to 7.2, several Layout permissions have been changed. Some pages restricted to the user Guest are accessible after the upgrade. There are rows in the ResourcePermission table with the value NULL on column primKeyId. It can be checked with the following...
Error handling LOB columns
Issue We have developed a custom entity using Service Builder. One of the tables defines a LOB column. When we try to insert a record in that column we get following database exception: java.lang.ClassCastException: javax.sql.rowset.serial.SerialBlob cannot be cast to oracle.sql.BLOB at...
Establish an external data source using JNDI
Issue Sometimes there is a requirement to use data sources other than Liferay DXPs. To do this, the data source can be configured via JNDI data source or JDBC properties. Any database other than Liferay DXP's database is referred to as an external database. The procedures outlined in...
Product status is not changing via headless APIs
Issue If the product is created via headless API with workflow-enabled. The status of the product is in a 'draft' state rather than a 'pending' state. Steps to reproduce: 1. Assign a default workflow to Commerce Product. 2. Create a product using headless API (POST /v1.0/products) 3....
Subfolder webcontent is not fetched with headless API
Issue Step to Reproduce: 1. Create three basic web content. 2. Create a folder with two basic web content inside it. Now, total web content is 5 including. 3. Navigated to http://localhost:8080/o/api 4. Executed the API request with following API:...
"Unable to extend the HTTP session" WARN logs
Issue These warnings are frequently found in the logs:  Unable to extend the HTTP session. or Unable to extend the HTTP session. Review the portal property "session.timeout" if this warning is displayed frequently Environment Liferay DXP 7.0 Fixpack 102+ Liferay DXP 7.1 Fixpack 25+...
INFO log traces with STARTED/ STOPPED information are not displayed when deploying a module if using WildFly/JBoss version 22.0.0 or higher
Issue When a module is started or stopped, there is usually a log trace of level INFO showing that information. However, when using the application server WidlFly/JBoss with version 22.0.0 or higher, these traces are not displayed. Environment DXP 7.3 until Fix Pack 3 Resolution To show...
Some pages do not display properly when HTTP Strict Transport Security (HSTS) is configured.
Please be aware that the page you are viewing has been machine translated from Japanese into English and may contain some translation errors. If you observe any issues with the translation, please contact us. Issue When HTTP Strict Transport Security (HSTS) is configured in tomcat, some...
Intermittent performance issues caused by Journal Articles Display
Issue After installing dxp-16, intermittent performance issues are being seen Thread dumps taken during the performance issue show a number of threads with a similar format: at java.util.regex.Pattern$Curly.match0(Pattern.java:4282) at...
Starting nodes concurrently can lead to incorrect module upgrades
Issue Module functionality seems to fail after moving to a newer fixpack. After executing a system:check unsatisfied dependencies like the following appear: Component with ID 58 is unavailable due to missing required dependencies:   service dependency...
Buttons inside SAML Admin not working
Issue Add Identity Provider button of SAML Admin is not clickable. Environment Liferay DXP 7.0 Liferay DXP 7.1 Liferay DXP 7.2 Liferay DXP 7.3 Liferay DXP 7.4 Resolution DXP 7.0, 7.1, 7.2 and 7.3: Add below properties in portal-ext.properties file and restart the server:...
'users.reminder.queries.enabled' portal property can be configurable from the UI on a per-instance basis
Issue Until now, the property 'users.reminder.queries.enabled' has been set to true or false per instance. However, after version DXP 7.3, the user is no longer able to do so (as the per-instance property file mechanism does not work anymore) Environment Liferay DXP 7.3 Resolution Using...
User should be re-directed to the custom page once the session expires
Issue Once the session expires, users should redirect to the custom page Environment Liferay DXP 7.0 Liferay DXP 7.1 Liferay DXP 7.2 Liferay DXP 7.3 Liferay DXP 7.4 Resolution To redirect the user to any page on session expire, the below session timeout redirect property should be set to...
Interactive commands is not working properly in Gogo Shell
Issue Steps to reproduce: 1. Connect with Gogo Shell via command line. 2. Type 'disconnect' command. Expected Result: The following question must appear after typing the command                                       "Disconnect from console? (y/n; default=y)" Actual Result:  The question...
StaleObjectStateException for RedirectNotFoundEntryImpl
Issue The StaleObjectStateException is appearing in logs for RedirectNotFoundEntryImpl. 2022-02-08 05:36:36.385 ERROR [https-jsse-nio-8443-exec-157][I18nFilter:62] org.hibernate.StaleObjectStateException: Row was updated or deleted by another transaction (or unsaved-value mapping was...
Is it possible to keep the session between domains that are not subdomains of a parent?
Issue Is it possible to keep the session in Liferay when changing from one domain to another domain? In particular, is this possible when the domains are not subdomains of a parent domain? Environment Liferay DXP 7.0+ Resolution Between subdomains of the same parent domain it is indeed...
Error using Service Builder when an entity has a BLOB field
Issue We define the following sample entity for Service Builder <entity name="Documentos" remote-service="false" local-service="true" uuid="false" table ="REAJ_GESTION_DOCUMENTO" data-source="extDataSource"> <column name="id" type="long" db-name="ID" primary="true" id-type="sequence"...
What does expires header with "Thu, 01 Jan 1970 00:00:00 GMT" value means?
Issue When retrieving HTML content the following header/value can be found: Expires: Thu, 01 Jan 1970 00:00:00 GMT  Along with the Expires header the following ones are also sent in the response: Cache-Control: private, no-cache, no-store, must-revalidate Pragma: no-cache Environment Any...
NullPointerException when starting JBoss EAP server
Issue After manually deploying Liferay on JBoss EAP, the JBoss EAP server can not be started due to the following ERROR [0m[31m08:50:29,397 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 80) MSC000001: Failed to start service...
Webcontent Images is getting removed after Patch Upgrade
Issue Steps to Reproduce: Start the 7.1GA1. Create a structure add text, image, and number fields, and save. Create a template. Select the newly created structure and select the structure fields from the left sidebar by clicking on each field (text, image & number) then save it. Create...
Establish an external data source using JDBC
Issue This article outlines how to set up a connection between Liferay and an external database using JDBC properties. Environment Liferay DXP 7.3 Liferay DXP 7.4 MySQL database Resolution There are two ways to connect Service Builder to an external database in Liferay:...
NullPointerException/ElasticsearchConnectionNotInitializedException/ArrayIndexOutOfBoundsException when starting JBoss EAP server
Issue After deploying Liferay DXP 7.3/7.4 on JBoss EAP server, the server can not be started due to the following error: 10:17:20,354 INFO 2022-02-17 10:17:20.308 ERROR [Framework Event Dispatcher: Equinox Container: b091645f-c27f-4506-9dd2-ba5088937c54][Framework:93] FrameworkEvent...
How to include the gradle dependency of a module into another module project?
Issue How to include the Gradle dependency of a module (Workspace A) into another module (Workspace B) project? Environment Liferay DXP 7.2 Resolution Please Note: Please choose to follow your appropriate discretion in the use of this information as these are not documented by Liferay....
JS and CSS files are loading only after page refresh
Issue JS and CSS files in portlet are loaded only after refreshing a page Environment Liferay DXP 7.2 Resolution Certain elements of the page may require regular navigation to work properly. In these cases, SPA must be disabled for those specific elements. Disabling SPA might help to...
Extracting Database structure of Liferay
Issue User needs to extract complete database structure of Liferay. Environment Liferay DXP 7.0 Liferay DXP 7.1 Liferay DXP 7.2 Resolution Liferay does not have any OOTB functionality for extracting the DB structure. However, same can be done using third party tools at user's own...
Apache Felix Webconsole JS and CSS resources not loaded
Issue Apache Felix Webconsole JS and CSS resources not loaded with 'org.eclipse.equinox.http.servlet' Steps to reproduce: 1. Start the server. 2. Download this: org.apache.felix.webconsole-4.6.4-all.jar from here:...
Unable to delete navigation menu from page
Issue Unable to remove the navigation menu widget from the page. Environment Liferay DXP 7.0 Resolution It is the intended behavior of Liferay as there is an option to enable Hidden from Navigation Menu Widget for all pages. Enabling the same in all pages(Site Administration -> Site...
Upgrade fails after installing dxp-24 because of deprecated constructor
Issue When running the upgrade tool after installing dxp-24, the upgrade can fail with the following error appearing in the upgrade logs: 2021-12-23 15:07:39.034 ERROR [Start Level: Equinox Container: d7a47fe3-6861-4df8-8478-363e9f54c836][VelocityTemplateResourceLoader:93] bundle...
java.sql.SQLException: Connection is closed error is continuously written to the log file.
Issue The error "java.sql.SQLException: Connection is closed" is continuously written to the log file. Caused by: java.sql.SQLException: Connection is closed  at com.zaxxer.hikari.pool.ProxyConnection$ClosedConnection$1.invoke(ProxyConnection.java:468)  at...
What is the alternate way to avoid clearing browser cache each time to reflect the Metal SOY module changes?
Issue What is the alternate way to avoid clearing browser cache each time to reflect the Metal SOY module changes? Environment Liferay DXP 7.2 Resolution First, clearing the cache is required as the browser stores the previously cached content of the module. For more information, go...
FreeMarker template com.sun.proxy.$Proxy975.getLatestArticle(long) error triggers
Issue Below "FreeMarker template com.sun.proxy.$Proxy975.getLatestArticle(long)" error triggers and this gets resolved after clearing the  server cache from server administration. The property "direct.servlet.context.reload " is disabled. 2021-08-18 20:14:26.885 ERROR...
Custom captcha validation using CaptchaUtil fails with error "Captcha Validation Failed"
Issue Custom captcha validation using CaptchaUtil API fails giving "Captcha Validation Failed" error in logs when having below code in jsp file: <liferay-captcha:captcha url="<%= captchaResourceURL %>"/>    Environment Liferay DXP 7.3 Resolution From Liferay DXP 7.3 the attribute urlis...
Liferay and application server logs are not capturing
Issue The Liferay log and application server log are not capturing the stack trace. And the size of these files is 0 in size with 3 to 4 lines of the log being traced. Environment Liferay DXP 7.2 Resolution Please Note: The following procedures and unofficial links involve customization,...
Log file size is 0
Issue Why the other log files size is 0. The files are "host-manager.xxxx-xx-xx.log, localhost.xxxx-xx-xx.log, manager.xxxx-xx-xx.log". Environment Liferay DXP 7.2 Resolution The other log files "host-manager.xxxx-xx-xx.log, localhost.xxxx-xx-xx.log, manager.xxxx-xx-xx.log" will be 0 in...
"Going to buffer response body of large or unknown size" warning triggers
Issue Why does the below warning trigger?  2021-08-18 20:14:27.334 WARN  [ajp-nio-8009-exec-795][HttpMethodBase:185] Going to buffer response body of large or unknown size. Using getResponseBodyAsStream instead is recommended. Environment Liferay DXP 7.2 Resolution This error says not to...
Liferay cluster works when truncating the crashed jgroupsping entries. Why does this happen?
Issue When recreating the pod during the pod start-up stage, clustering doesn't work properly, and the below error triggers. But, the Liferay cluster works perfectly post restarting the pods by truncating the entries in the JGroupsPing tables. Why does this happen? -0-58215:...
Data providers lead to NPEs during a DXP 7.0 to DXP 7.2 upgrade
Issue A Data Provider configured in DXP 7.0 can lead to NullPointerExceptions when upgrading to DXP 7.2 Steps to reproduce: 1. Start Liferay DXP 7.0 server 2. Navigate to Forms -> Data Providers -> Add REST Data Provider 3. Fill out the Data Provider and Save 4. Shutdown the DXP 7.0...
Log4j warnings after upgrading to Fix Pack 15
Issue After upgrading Liferay DXP 7.2 to Fix Pack 15, the following warnings and error are printed in the logs on startup: log4j:WARN Continuable parsing error 3 and column 30 log4j:WARN Document root element "Configuration", must match DOCTYPE root "null". log4j:WARN Continuable parsing...
During a two-way SSL handshake, an exception is thrown
Issue During a two-way SSL handshake, the following exception occurs. javax.net.ssl|WARNING|DC|tomcat-http--46| EDT|SSLSocketImpl.java:1428|handling exception ( "throwable" : { java.lang.NullPointerException at org.bouncycastle.crypto.signers.PSSSigner.generateSignature(Unknown Source)...
Service Access Policy configuration file
Issue Users are unable to export and save the configurations set by the Service Access Policy. Steps to reproduce: 1) Start a clean bundle of Liferay DXP 7.2 2) Navigate to Control Panel -> Configuration -> Service Access Policy -> System_Default and edit the Title 3) Save the...
Upgrading From Fix Pack 8 to 11 Failed Due To NPE
Issue After upgrading from fix pack 8 to 11, the portal starts up with NPE. 2022-01-06 12:42:49.469 ERROR [default task-1][MainServlet:1168] com.liferay.portal.kernel.events.ActionException: java.lang.NullPointerException ...... Caused by: java.lang.NullPointerException at...
What file upload protocol is used by Liferay?
Issue We need information about the file upload protocol that is used by Liferay in the file upload functionality from the users' browsers. This information is necessary to fix some network issues in the firewall and other related elements. Environment Any Liferay version Resolution In...
java.lang.RuntimeException: com.liferay.portal.lpkg.deployer.LPKGVerifyException: LPKG validation failed
Issue Why "LPKGVerify RuntimeException" triggers? SEVERE: Exception sending context initialized event to listener instance of class com.liferay.portal.spring.context.PortalContextLoaderListener java.lang.RuntimeException: com.liferay.portal.lpkg.deployer.LPKGVerifyException: LPKG...
"The activate method has thrown an exception java.nio.file.NoSuchFileException:" reported for bundle com.liferay.portal.osgi.web.wab.generator.impl when starting server
Issue "The activate method has thrown an exception java.nio.file.NoSuchFileException: + {path}" reported for bundle com.liferay.portal.osgi.web.wab.generator.impl when starting server. 2021-12-23 05:46:17.220 ERROR [main][WabGenerator:93] bundle...
Options are not available to configure while selecting the "Remote Cluster Connection ID"
Issue After portal upgrade, when updating the elastic search in DXP 7.3, options are not available to configure while selecting the "Remote Cluster Connection ID". And the below error triggers at the same time span when this activity is performed. 2021-09-15 01:57:37.319 ERROR...
SearchEngineUtil.search equivalent in Liferay 7.2
Issue Liferay 6.2 class SearchEngineUtil equivalent in Liferay 7.2. Environment Liferay DXP 7.2 Resolution The below document includes the replaced classes of the deprecated ones....
Unable to create a SAML certificate using Document Library Keystore Manager
Issue Unable to create a SAML certificate using Document Library Keystore Manager with Google Cloud Storage There was a problem loading the SAML Keystore. Please contact your system administrator. Environment Liferay DXP 7.3 Resolution The observed behavior is a known issue LPS-146269...
Some management toolbars do not display the stored display style
Issue Changing the display view when in the People section does not remain if you navigate away to a different page. Steps to reproduce Start a clean bundle of Liferay DXP 7.2. Go to People -> Memberships and change the view from "Cards" to "Table" Go to People -> Teams, and then back to...
When entries in the jgroupsping table are not removed, clustering does not always work properly
Issue With two Liferay 7.2 SP3 nodes, configured unicast clustering. However, it has been observed that clustering does not always work properly and that the cluster returns to normal operation when the entries in the jgroupsping table are deleted. The following errors have been...
Why aren't Headless API calls working after I change the Root context?
Issue I changed Liferay's root context to a custom context, and now headless API calls are returning "access denied" errors. Environment DXP 7.3 Resolution This issue is fixed by LPS-143355  Additional Information Read more about Headless Delivery  , content:...
Is that NTLM solution works when the user should land on the home page automatically instead of getting a login page as long as the portal has connected to the client machine or the network?
Issue Is that NTLM solution works when the user should land on the home page automatically instead of getting a login page as long as the portal has connected to the client machine or the network? Environment Liferay DXP 7.3 Resolution NTLM authentication was deprecated from Liferay DXP...
Is there a way to find out which osgi module owns a jar that's been written to the $liferay_home/osgi/state directory?
Issue I would like to find out which osgi module owns a jar that's been written to the $liferay_home/osgi/state directory. Environment DXP 7.2 DXP 7.3 Resolution  The id of the bundles in Gogo Shell corresponds to the subfolder names in osgi/state/org.eclipse.osgi . To see all the bundle...
Why are Exports Slow In a Site With a Large Number of PDF Documents?
Issue When I attempt an export of a site containing a large number of PDF documents in DXP 7.3, the export takes a very long time. Environment DXP 7.3 Resolution This issue is resolved by LPS-142761   Additionally, the following workaround speeds up export time: On the export screen,...
Liferay fails to start up after installing fix pack
Issue After installing a fix pack, sometimes the environment may not start back up and will encounter the following error: 10-Nov-2021 18:14:07.441 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.listenerStart Exception sending context initialized event to...
Cannot start up server after applying a new patch
Issue After installing a new fix pack / hotfix, the portal is not starting up, even though the temporary folders have been deleted. 06-Dec-2021 13:15:32.439 SEVERE [main] org.apache.catalina.core.StandardContext.listenerStart Exception sending context initialized event to listener...
Liferay fails to manage unique session and displays the mismatched data of the users
Issue Liferay fails to manage unique sessions and displays the mismatched data of the users when using the below code ThemeDisplay td = (ThemeDisplay) renderRequest.getAttribute(WebKeys.THEME_DISPLAY); User user = td.getUser(); String clientId = user.getScreenName().toUpperCase();...
Service "com.liferay.portal.kernel.messaging.DestinationFactory" is unavailable
Issue What does this error mean? When it will occur? 2021-07-21 00: 02: 06.207 ERROR [ServerService Thread Pool - 111] [ServiceProxyFactory: 109] Service "com.liferay.portal.kernel.messaging.DestinationFactory" is unavailable in 60000 milliseconds while setting field "...

該当件数: 8,813 件中 7,441 - 7,500