Search Results

All Results 6925
Sort By
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Common Errors with Database Sharding in DXP 7.0
This article documents the issues with setting up a sharded database and lists steps to resolve the issue or avoid it altogether. Resolution Error: Users are unable to create content specifically on a sharded database in Liferay DXP 7.0. Summary: Database Sharding settings in the...
NamingException Error on WebSphere 6.x
This article is a legacy article. It applies to previous versions of the Liferay product. While the article is no longer maintained, the information may still be applicable. When Liferay Portal is running on a Websphere Application Server 6, a NamingException error is thrown. Example:...
Possible Performance Issue Caused by LPS-48693
Before the portal-84-6210 fixpack, the DDMTemplate editor UI was missing the cacheable checkbox. This issue caused each DDMTemplate that was saved into the DB to not be cached. This article provides a solution to a potential heavy performance drop casued by XML parsing and template...
Upgrade halts with "ALTER TABLE" exception
This article is a legacy article. It applies to previous versions of the Liferay product. While the article is no longer maintained, the information may still be applicable. Liferay Support does not recommend or endorse specific third-party products over others. Liferay is not...
Avoiding SAXParser Exceptions
By default, the Liferay platform does not define a SAXParser. But please note that a SAXParser contains the logic that can parse XML files. Liferay does not define a SAXParser because certain setups (e.g. Weblogic) may already have a SAXParser; trying to override them with Liferay's own...
Trouble Starting Portal If 'Java_Home/bin' Is Not Defined in Path Variable
This article describes a known issue where the platform may not start if JAVA_HOME/bin is not defined in the PATH variable. DXP 7.0 and 7.1 requires JAVA_HOME and PATH variables to be set. However, the platform only needs JAVA_HOME set. If JAVA_HOME/bin is not set in the PATH variable or...
Known Issues with Core-5
This article is a legacy article. It applies to previous versions of the Liferay product. While the article is no longer maintained, the information may still be applicable. This article outlines a small set of issues that exist within the core-5 fix pack as well as their resolutions....
DXP Fails to Generate Captchas and Charts on RHEL 7.4
When using RHEL 7.4, and viewing a captcha, or when navigating to Control Panel > Configuration > Server Administration, the following stack trace will appear in the application server logs. That is catalina.out for Tomcat. Caused by: java.lang.ArrayIndexOutOfBoundsException: 0 at...
ConcurrentModificationException When Deploying Plugins on Liferay Portal 6.1 EE GA3
This article outlines a specific known issue that exists within Liferay Portal 6.1 EE GA3 SP3 and provides a link to follow its resolution. Resolution At the time of release, there is one known issue with Liferay Portal 6.1 EE GA3 SP3. In this version of Liferay, a...
Difficulty Adding Assets That Use Alloy Editor on Windows Os in DXP 7.0
This articles serves as a troubleshooting guide for users working in Liferay DXP 7.0. When it comes to adding assets using the alloy editor on Windows OS, you may encounter some difficulties. The browser may display a ReferenceError: CKEDITOR is not defined, and the console may...
Resolving 'UnsupportedOperationException' Caused by an Invalid Audit Max Queue Size Setting
This article documents steps on how to increase the audit message max queue size that leads to an UnsupportedOperationException.  By default, System Settings > Foundation > Audit > "Audit message max queue size" is set at 200. The value is supposed to be greater than 0. This specific...
X-FRAME-Options Reference Guide
This article is to help those who wish to change the X-Frame-Options in Liferay Digital Experience Platforms. Usually, this is required if you are trying embedding widgets in a portlet or an iFrame so that HTTP headers are protected against clickjacking. These values are found in the...
Tomcat JDBC Connection Exhaustion
This article helps troubleshooting MySQL when executing the VerifyProcess. Small Max JDBC Connection Pool causes JDBC Connection Exhaustion if the VerifyProcess is executed concurrently; when a user has a max Tomcat JDBC Connection Pool size configured or defined as less than the numbers...
Unicast with JGroups (RMI)
Liferay Support does not recommend or endorse specific third-party products over others. Liferay is not responsible for any instructions herein or referenced regarding these products. Any implementation of these principles is the responsibility of the subscriber. This article outlines...
Upgrading to Liferay Portal 6.1 EE
With the release of Liferay 6.1 EE GA1, Liferay introduced the Seamless Upgrade feature. Seamless upgrades allow users to upgrade to the latest version of Liferay by simply pointing the latest version of Liferay to the database of the older version. This does not diminish the fact that...
Changing the Liferay Logs Directory
This article documents how to change the Liferay logs directory from the default [LIFERAY_HOME]/logs to another desired path.  Resolution Steps to Change the Liferay Logs Directory Unzip the files log4j.dtd and portal-log4j.xml from [Liferay WAR]/WEB-INF/lib/portal-impl.jar...
Portal Best Practices
This article is a legacy article. It applies to previous versions of the Liferay product. While the article is no longer maintained, the information may still be applicable. The following article lists a number of various "best practices" to keep in mind when using the Portal. The list...
Upgrade Process properties are not needed anymore
Prior to Liferay Portal 6.1, the upgrade process required that "upgrade.process" property to be set in the portal-ext.properties. For example, consider an upgrade from Liferay Portal 5.2 to Liferay Portal 6.0 SP2. Before Liferay Portal 6.1, the user would point the Portal 6.0 SP2  to the...
[Upgrade] Handling Quartz Data during Liferay Portal Upgrades
Quartz data is a unique type of data. If quartz data is part of the database upgrade, then there are some potential additional steps to take during the upgrade process. Resolution If there are not any publishing jobs, simply dump the data in the old scheduler and the upgrade process will...
Backslashes in Screen Name Are No Longer Valid After Upgrading to Liferay Portal 6.2
After upgrading from Liferay Portal version 5.2 EE SP4 to 6.2 EE, backslashes in the screen name are not allowed when using the liberal screen name validator. In Portal 5.2, backslashes were allowed in the screen name. Resolution The ability to add backslashes in the screen name was...

Showing 8,061 to 8,080 of 8,813 entries.