Search Results

All Results 6925
ソート
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Product specifications are not getting created if not available on the portal
Issue When specifications are not available on the portal. It's giving 500 Internal Server Error in the response body while creating the product via headless API. Steps to reproduce: 1. Create a product by using POST /v1.0/products (Request is attached). 2. Below is the Request for...
Product status is not updating by using Patch API
Issue PATCH API is not updating the status of the product workflow. Steps to reproduce: 1. Create a product via headless API( request is attached). 2. Check the status of the product in UI ( It's showing as draft status). 3. Use the Get API for fetching the response of the created...
Old auditing data taking up database space
Issue Are there any alternative methods to manage audit data? Environment DXP 7.3   DXP 7.2 Resolution As an alternative to saving all of the logging data into the database, instead, we may choose to save it to a JSON or CSV file. The same disk space requirements remain, but it can...
Audit modules is not starting after upgrade
Issue After upgrading from Liferay Portal 6.2 to Liferay 7.2. The following audit module error is appearing. 2020-11-05 10:07:14.615 INFO [Start Level: Equinox Container: 69cf58a7-c02f-4bb9-a8ed-60445fa81573][UpgradeProcess:93] Upgrading...
Troubleshooting java.lang.NoClassDefFoundError and java.lang.ClassNotFoundException Optional Dependency Errors
Issue When starting up Liferay, the following errors are observed: java.lang.NoClassDefFoundError or java.lang.ClassNotFoundException. Environment Liferay DXP with deployed custom modules including optional dependencies. Resolution Review the deployed MANIFEST.MF inside the module or the...
Layout permissions lost upgrading from 6.2 to 7.2
Issue After the upgrade from 6.2 to 7.2, several Layout permissions have been changed. Some pages restricted to the user Guest are accessible after the upgrade. There are rows in the ResourcePermission table with the value NULL on column primKeyId. It can be checked with the following...
Error handling LOB columns
Issue We have developed a custom entity using Service Builder. One of the tables defines a LOB column. When we try to insert a record in that column we get following database exception: java.lang.ClassCastException: javax.sql.rowset.serial.SerialBlob cannot be cast to oracle.sql.BLOB at...
Establish an external data source using JNDI
Issue Sometimes there is a requirement to use data sources other than Liferay DXPs. To do this, the data source can be configured via JNDI data source or JDBC properties. Any database other than Liferay DXP's database is referred to as an external database. The procedures outlined in...
Product status is not changing via headless APIs
Issue If the product is created via headless API with workflow-enabled. The status of the product is in a 'draft' state rather than a 'pending' state. Steps to reproduce: 1. Assign a default workflow to Commerce Product. 2. Create a product using headless API (POST /v1.0/products) 3....
Subfolder webcontent is not fetched with headless API
Issue Step to Reproduce: 1. Create three basic web content. 2. Create a folder with two basic web content inside it. Now, total web content is 5 including. 3. Navigated to http://localhost:8080/o/api 4. Executed the API request with following API:...
"Unable to extend the HTTP session" WARN logs
Issue These warnings are frequently found in the logs:  Unable to extend the HTTP session. or Unable to extend the HTTP session. Review the portal property "session.timeout" if this warning is displayed frequently Environment Liferay DXP 7.0 Fixpack 102+ Liferay DXP 7.1 Fixpack 25+...
INFO log traces with STARTED/ STOPPED information are not displayed when deploying a module if using WildFly/JBoss version 22.0.0 or higher
Issue When a module is started or stopped, there is usually a log trace of level INFO showing that information. However, when using the application server WidlFly/JBoss with version 22.0.0 or higher, these traces are not displayed. Environment DXP 7.3 until Fix Pack 3 Resolution To show...
Some pages do not display properly when HTTP Strict Transport Security (HSTS) is configured.
Please be aware that the page you are viewing has been machine translated from Japanese into English and may contain some translation errors. If you observe any issues with the translation, please contact us. Issue When HTTP Strict Transport Security (HSTS) is configured in tomcat, some...
Intermittent performance issues caused by Journal Articles Display
Issue After installing dxp-16, intermittent performance issues are being seen Thread dumps taken during the performance issue show a number of threads with a similar format: at java.util.regex.Pattern$Curly.match0(Pattern.java:4282) at...
Starting nodes concurrently can lead to incorrect module upgrades
Issue Module functionality seems to fail after moving to a newer fixpack. After executing a system:check unsatisfied dependencies like the following appear: Component with ID 58 is unavailable due to missing required dependencies:   service dependency...
Buttons inside SAML Admin not working
Issue Add Identity Provider button of SAML Admin is not clickable. Environment Liferay DXP 7.0 Liferay DXP 7.1 Liferay DXP 7.2 Liferay DXP 7.3 Liferay DXP 7.4 Resolution DXP 7.0, 7.1, 7.2 and 7.3: Add below properties in portal-ext.properties file and restart the server:...
'users.reminder.queries.enabled' portal property can be configurable from the UI on a per-instance basis
Issue Until now, the property 'users.reminder.queries.enabled' has been set to true or false per instance. However, after version DXP 7.3, the user is no longer able to do so (as the per-instance property file mechanism does not work anymore) Environment Liferay DXP 7.3 Resolution Using...
User should be re-directed to the custom page once the session expires
Issue Once the session expires, users should redirect to the custom page Environment Liferay DXP 7.0 Liferay DXP 7.1 Liferay DXP 7.2 Liferay DXP 7.3 Liferay DXP 7.4 Resolution To redirect the user to any page on session expire, the below session timeout redirect property should be set to...
Interactive commands is not working properly in Gogo Shell
Issue Steps to reproduce: 1. Connect with Gogo Shell via command line. 2. Type 'disconnect' command. Expected Result: The following question must appear after typing the command                                       "Disconnect from console? (y/n; default=y)" Actual Result:  The question...
StaleObjectStateException for RedirectNotFoundEntryImpl
Issue The StaleObjectStateException is appearing in logs for RedirectNotFoundEntryImpl. 2022-02-08 05:36:36.385 ERROR [https-jsse-nio-8443-exec-157][I18nFilter:62] org.hibernate.StaleObjectStateException: Row was updated or deleted by another transaction (or unsaved-value mapping was...

該当件数: 8,813 件中 7,441 - 7,460