Search Results

All Results 6931
Sort By
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Can not connect to an external service using port 25
Issue It is not possible to establish a connection to an external service from Liferay Cloud using the port 25, commonly used for email sending/receiving purposes. Environment Liferay Cloud Resolution Port 25 is always blocked by several Cloud providers (including our solution) due to...
Can not install a hotfix due to folder permission errors
Note: please note that Liferay has renamed its Liferay Experience Could offerings to Liferay SaaS (formerly LXC) and Liferay PaaS (formerly LXC-SM). Issue Can not install a hotfix due to folder permission errors as following: liferay[liferay-xx] ## Hot fix liferay[liferay-xx] ##...
Can not associate an User Segment to a Content set
Issue In Site management > Content & Data > Collections > Add a new manual selection > Add a new personalized variation, it is not possible to select a User segment from the list after changing the number of entries per page at the bottom left of the popup window. Environment Liferay DXP...
Can not generate a build from Bitbucket due to status 401 (unauthorised) error on Jenkins service
Note: please note that Liferay has renamed its Liferay Experience Could offerings to Liferay SaaS (formerly LXC) and Liferay PaaS (formerly LXC-SM). Issue After trying to integrate your Bitbucket repository, builds are not being generated and the following error is observed on the CI...
JSP fragments modules do not get Resolved after being deployed
Note: please note that Liferay has renamed its Liferay Experience Could offerings to Liferay SaaS (formerly LXC) and Liferay PaaS (formerly LXC-SM). Issue JSP fragment modules don't get Resolved after being deployed via environment folders on /lcp/liferay/deploy/  Environment Liferay...
How to enable simultaneous login from multiple sessions
Issue How to enable users to simultaneously login to Liferay DXP using multiple different sessions Environment Liferay DXP Resolution Add the following lines to your portal-ext.properties file (you must include both of them otherwise it will not work): auth.simultaneous.logins=true...
Stuck reindex: How to check the progress of a reindex process and remove blocked BackgroundTask and Lock records
Symptom Sometimes a reindex will take a long time and seem like nothing is happening. You simply see the reindex icon in the Control Panel bar and/or the percentage does not change.  Environment DXP 7.4 DXP 7.3 DXP 7.2 DXP 7.1 DXP 7.0 Resolution Since this resolution requires...
After 7.0 > 7.1 or 7.2 theme upgrade, the menu to edit web contents will no longer be available
Issue After upgrading to DXP 7.1 or 7.2 a 7.0 DXP theme created with the Liferay Theme Generator according to e.g. this tutorial: Upgrading Your Theme from Liferay Portal 7.0 to 7.2, the Web Content Display widget showing a piece of web content will no longer have the menu options to...
Module download link can not be opened on Liferay DXP Release Notes page with 404 error
Issue  When trying to download modules like "com.liferay.saml.opensaml.integration" from Liferay DXP Release Notes page, the download link can not be opened with a 404 error. Environment Liferay DXP 7.2 Resolution Modules like "com.liferay.saml.opensaml.integration" is included...
How to Modify Home Folder permissions
Issue Guests who don't have view permissions for the Home Folder cannot view any Web Content when the Article view permissions check enabled option is checked. Environment Liferay 7.1+ Resolution The Home folder permissions can be modified with the following steps: Navigate to Site...
Users with role Site Member cannot find other users in search results
Issue Users with role Site Member cannot find other users in search results. Environment Liferay DXP 7.0 Liferay DXP 7.1 Liferay DXP 7.2 Resolution This is the expected behavior. For security reasons, by default the permission to view other users' data is only given to administrators....
How to connect DXP 7.2 to Elasticsearch over SSL/TLS using PKI authentication where native realm is disabled on Elasticsearch
Issue Once DXP 7.2 is configured with Elasticsearch 6.x or 7.x over SSL/TLS in the specific scenario where Elasticsearch uses PKI authentication with username-password disabled, NoNodeAvailableException is thrown during Liferay startup: Caused by: java.lang.RuntimeException:...
Liferay Cloud cookies
Issue Description about the cookies used in Liferay Cloud platform and their services. Environment Liferay Cloud Resolution Google Analytics cookies: _gat: Numeric It is used to limit the percent request. Term: 1 minute _ga: Identifier It is used to identify users Term: 2 years _gid:...
How to identify the version of Clay under DXP?
Issue As a developer, I would like to identify the exact version of Clay on the specific DXP version (and patch level) which is currently running. Environment DXP 7.1 Resolution Please go to Control Panel -> System Settings -> Javascript Loader and enable the option Explain module...
Liferay DXP cannot be started correctly due to "Unable to initialize Elasticsearch cluster" errors
Issue The server can not be started correctly with ES errors like the following: 2020-06-05 06:45:41.596 ERROR [Framework Event Dispatcher: Equinox Container: 2a6f419e-c609-4e73-a180-4e901fcc9b18][Framework:93] FrameworkEvent ERROR java.lang.IllegalStateException: Unable to initialize...
Connect to LDAP via VPN for Liferay Cloud
Note: please note that Liferay has renamed its Liferay Experience Could offerings to Liferay SaaS (formerly LXC) and Liferay PaaS (formerly LXC-SM). Liferay DXP supports LDAP connectivity, and Liferay Cloud provides VPN capabilities to connect to an on-premise network. In this article,...
How to resolve Document Library PDF previews taking up more disk space than the original files
Issue While examining our document library in a file system, we saw that the storage being used for preview files are taking up three times the amount of disk space as the storage for the original files uploaded to documents and media, leading to disk space usage issues. In particular,...
How to check Bootstrap version under DXP?
Issue As a developer, I would like to check what exact Bootstrap version is applied on the currently running DXP version (and patch level). Environment DXP 7.0+ Resolution Navigate to DXP and open the browser console Insert the following line to console...
Known Issue: Buttons don’t work with SPA disabled and when using Google Chrome 83.0.4103.61
Issue When using Google Chrome v. 83.0.4103.61 in combination with SPA disabled (javascript.single.page.application.enabled=false in portal-ext.properties), several buttons will no longer work Environment Liferay DXP 7.0+ Resolution Upgrade to Google Chrome v. 83.0.4103.97+  , content:...
Is Liferay Product affected by OpenSSL security issue CVE-2020-1967 ?
Issue Is Liferay Product affected by OpenSSL security issue CVE-2020-1967 ? Environment Liferay DXP 7.1 Resolution Since Liferay products do not come with OpenSSL built-in, Liferay is not affected by CVE-2020-1967 out of the box. If you have implemented OpenSSL into your project, your...

Showing 3,641 to 3,660 of 8,843 entries.