Search Results

All Results 6932
Sort By
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Overriding Core Classes with Ext Plugins
A supported use case for using Ext plugins in Liferay DXP is overriding Liferay DXP's core classes (e.g., portal-impl, portal-kernel, etc.). You can reference the Finding Core Liferay Portal Artifacts section for help distinguishing core classes. Make sure you've reviewed the generalized...
Glassfish Admin Console Is Not Accessible
With JDK version 1.6.0_19, and above, Glassfish admin console is not accessible with Liferay Portal. Steps to Reproduce Download Liferay Portal 6.1 EE GA3 or Portal 6.2 Glassfish 3 bundle. Unzip. Run server, wait while it will be started. Try to access Glassfish Admin Panel. Resolution...
Adding to the web.xml With Ext Plugins
A supported use case for using Ext Plugins in Liferay DXP is adding additional functionality to Liferay DXP's web.xml file. Before beginning, make sure you've reviewed the generalized Customization with Ext Plugins tutorial. As an example, you'll create a sample Ext plugin that adds to...
Modifying Liferay DXP's web.xml file
A supported use case for using Ext Plugins in Liferay DXP is modifying Liferay DXP's web.xml file. Before beginning, make sure you've reviewed the generalized Customization with Ext Plugins tutorial. As an example, you'll create a sample Ext plugin that modifies your Liferay DXP's...
Why was my custom domain rejected by Liferay PaaS?
Note: please note that Liferay has renamed its Liferay Experience Could offerings to Liferay SaaS (formerly LXC) and Liferay PaaS (formerly LXC-SM). Issue Why was my custom domain rejected by Liferay PaaS? Environment Liferay PaaS Resolution If you have configured your domain but Liferay...
Connection Timeout Caused by 'org.dom4j.DocumentException' When Deploying Portlet, Hook, Etc.
Liferay Support does not recommend or endorse specific third-party products over others. Liferay is not responsible for any instructions herein or referenced regarding these products. Any implementation of these principles is the responsibility of the subscriber. Some environments fail...
Users May Appear in the Database but Not in Liferay Control Panel
You may encounter an issue where specific users, or a group of users, are not appearing with the Control Panel. If upon querying the relevant tables in the database you are able to see these users, then it is likely that there is simply a discrepancy between the database and the index....
NoSuchGroupException' Occurs When Deleting Deactivated Users
When deleting deactivated users from UI or through API, NoSuchGroupException is thrown as follows. Example 1 com.liferay.portal.NoSuchGroupException No Group exists with the key {companyId=10155, classNameId=10191, classPK=48798001} Example 2 com.liferay.portal.NoSuchGroupException...
Default Landing Page Action Is Not Supported When Using Third-Party Authentication Mechanism
Liferay Support does not recommend or endorse specific third-party products over others. Liferay is not responsible for any instructions herein or referenced regarding these products. Any implementation of these principles is the responsibility of the subscriber. Third-party...
Enabling Directory Indexing
Description If directory indexing is enabled, document libraries are browsable through the URL not only for site admins but for anyone according to the default Document Library permissions. This could result in permission / security issues with documents being viewable by incorrect...
Cluster Fails to Start Up Due to JGroups Update
Liferay Support does not recommend or endorse specific third-party products over others. Liferay is not responsible for any instructions herein or referenced regarding these products. Any implementation of these principles is the responsibility of the subscriber. This article describes a...
Changing the total number of fields in the index for Elasticsearch through DXP
This article documents how to increase the maximum number of fields in the Elasticsearch index through the Control Panel in DXP 7.0, 7.1, 7.2, and 7.3.  The default settings are set to 7500 fields and there is normally no need to exceed 7500 fields. Increasing the total number of fields...
Search portlet does not automatically reindex when new user is added
This article is a legacy article. It applies to previous versions of the Liferay product. While the article is no longer maintained, the information may still be applicable. The intended behavior of the Liferay Portal is to automatically reindex when any user is updated or created....
Sending e-mail by announcement portlet
Please be aware that the page you are viewing has been machine translated from Japanese into English and may contain some translation errors. If you observe any issues with the translation, please contact us. Event/Use Case Depending on the announcement portlet, there is a function to...
Troubleshooting Activation Key Issues
For customers working on Liferay DXP, Liferay Commerce or Liferay Portal, this article serves as a troubleshooting guide for activation key issues. Table of Contents Reading Folders and Logs Reading the License Manager Checking the Deploy Directory The *.li exists in data folder...
Users Fail to Import When First Name is Missing in LDAP
 This article discusses an apparent issue when Liferay Portal will throw a ContactFirstNameException error in the console. This error message appears when the first name is left out if importing a user from an LDAP server. Resolution This behavior is intended for Liferay Portal. Liferay...
Staging Issues with Blogs Portlet
 The following is a checklist for getting blogs to stage if you're experiencing difficulties. While the example is blogs, this could apply to any content. Resolution When attempting to stage blog content: Before turning on staging, be sure to check Blogs. By default, Blogs are not...
Group Mapping Left Blank In LDAP Export Leads to Errors
This articles serves as a troubleshooting guide. When Liferay is configured to export users from the portal to LDAP, the following error is encountered: 09:18:31,903 ERROR [LoginAction:128] com.liferay.portal.ModelListenerException: javax.naming.directory.InvalidAttributeValueException:...
LDAP Authentication and User Import/Export
This article provides an overview of LDAP integration with Liferay DXP 7.0. This content on authentication, user Import/Export, configurations, upgrade considerations and what has changed from previous Liferay Portal versions, is intended to help readers successfully integrate LDAP with...
SQL Server Database May Lock When Publishing Content in a Staged Environment or Importing a LAR
Liferay portal may appear to hang or be unresponsive when importing a LAR or publishing to staging. This occurs if the database used in your environment is a SQL Server with default transaction isolation settings and it occurs regardless of the size of the content. Resolution 1. Set in...

Showing 6,021 to 6,040 of 8,839 entries.