Search Results

All Results 6909
Sort By
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
com.liferay.portal.kernel.exception.NoSuchCompanyException: No Company exists with the key {webId=liferay.com}
Issue When starting a new cluster installation of Liferay 7.3, this error appears, and then I cannot access to Liferay's Control Panel and other functionalities. ERROR [main][PortalInstances:261] com.liferay.portal.kernel.exception.NoSuchCompanyException: No Company exists with the key...
Failed upgrade process for module com.liferay.journal.service
Issue During your upgrade process, you might encounter an error during the com.liferay.journal.internal.upgrade.v1_1_0.DocumentLibraryTypeContentUpgradeProcess step: Caused by: com.liferay.portal.kernel.xml.DocumentException: Error on line 12 of document  : The reference to entity "S"...
How to add Sample Data to Liferay DXP?
Issue While this might be a simple thing to do, the way to do this may be unknown to most Liferay users. Environment Liferay DXP Resolution Whenever you're first setting up your Liferay DXP server, you'll find the setup wizard section as soon as it launches. In order to add Sample Data...
Basic document file entry type group id is zero
Issue After upgrade to DXP 7.4 U67 from 7.0, in DLFileEntryType table the entry for Basic Document type has the following fields set to zero: fileEntryTypeId, groupId, companyId, userId. Is this the intended behavior? Environment DXP 7.4 Resolution In a clean 7.4 database, we see that...
Remove "Danger" alert for users when session times out
Issue In Liferay portal, when the session is inactive, the users are seeing "Danger: Due to inactivity your session timed out." Environment Liferay DXP 7.0+ Resolution It is possible to disable the notification, by using the following property: "session.timeout.warning=0" in the...
Getting the Liferay Session ID in Javascript
Issue We can't extract the session ID using JavaScript, because the Liferay.ThemeDisplay.getSessionId() function consistently returns an empty string. Environment Liferay DXP 7.4 Resolution By default, the Liferay.ThemeDisplay.getSessionId() function will always return a blank string. To...
Second java process running on Liferay server
Issue On our production Liferay server we just saw a second java process running with these arguments: java -cp...
How to trigger test emails from Liferay?
Issue We have configured our SMTP in Liferay. We would like to test if emails are sent and received. How can we trigger a test email from Liferay?   Environment Liferay DXP 7.4   Resolution You can use the attached groovy script to send an email from Liferay. Change the script to add...
Does the Admin user have to be active to upgrade Liferay?
Issue We are going to upgrade our Liferay portal and would like to know if there is any problem if the Admin user is inactive. Environment Liferay DXP 7.4 Resolution To perform the Liferay upgrade it is not necessary for the user with the Administrator role to be active. Additional...
Web Content Templates error: ORA-00932, during sorting them
Issue Experiencing a misbehavior after trying to sort the Web Content Templates: ERROR [http-nio-8080-exec-10][render_portlet_jsp:131] null ERROR [http-nio-8080-exec-7][SqlExceptionHelper:142] ORA-00932: inconsistent datatypes: expected - got CLOB Environment DXP 7.4 Resolution...
OSGi configuration disappears
Issue Settings performed through OSGi appear to be lost. Environment Liferay DXP Resolution Check the following aspects: Database: If portal is pointing to a wrong database where configuration isn't defined default configuration settings will be applied. FileSystem: If .config file was...
Service Builder fails to build modules if trash-enabled="true" is added as a property
Issue If the service builder entity has the attribute trash-enabled="true" defined, the corresponding abstract methods were generated for the model & wrapper classes(FooModel, FooModelImpl, FooWrapper) for Liferay dxp 7.4.13.u18 & earlier bundles. However, the service builder for Liferay...
NullPointerException during portal startup in ModuleFrameworkImpl._setUpInitialBundles
Issue Portal immediately fails to start due to a exception like the following one: Caused by: java.lang.reflect.InvocationTargetException at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at...
Incorrect FieldReference is used when adding a Document of a nonstandard Document Type
Issue When uploading a Document, the ddmFormValuesMap that is passed to the addFileEntry API has the wrong fieldReference. The fieldReference is set to the name instead of the fieldReference. While the fieldReference and name are often the same (by default), they are not necessarily so....
Alternatives to ClamAV antivirus service
Issue Is there any way to integrate with other antivirus services (such as Sophos or Windows Defender) in place of ClamAV? Environment DXP 7.4 Resolution Unfortunately, there are no other options besides ClamAV.  ClamAV works because you can pass it a stream of data and scan on command...
ORA-00001 WARN: unique constraint
Issue When upgrading from DXP 7.2 to 7.4 U53 using an Oracle database, we faced the following WARN message: ORA-00001: unique constraint (PORTALESLIFERAY1.IX_CB778855,  nos podeis decir a que se debe y si afecta al proceso de acutalización del producto....
How to check jar versions of certain marketplace apps
Issue You might use our OOTB jars to build your modules and for that reason you wish to know the version before an upgrade process, for example Environment Liferay DXP 7.0+ Resolution Navigate to liferay_home/osgi/marketplace/ and find the desired lpkg Inside the lpkg you will find the...
NullPointerException - liferay/monitoring
Issue You might encounter some excessive logging in your portal related to Liferay Monitoring: ERROR [liferay/monitoring-982][ParallelDestination:59] Unable to process message {destinationName=liferay/monitoring, response=null, responseDestinationName=null, responseId=null, payload=[...]...
How to modify API URL?
Issue If we are removing the /o/ from URLs, they are not recognised anymore. Environment Liferay DXP 7.1+ Resolution You can create a hostname e.g. api.something.com and have Apache (or Nginx) do the proxy pass to Liferay with /o.   Below is a sample configuration could be implemented...
"No User exists with role Administrator" error seen when upgrading Liferay
Issue "No User exists with role Administrator" error is seen when upgrading major Liferay versions, as follows: ERROR [main][VerifyProcessTrackerOSGiCommands:323] null com.liferay.portal.verify.VerifyException: com.liferay.portal.kernel.exception.NoSuchUserException: No user exists in...

Showing 7,181 to 7,200 of 8,795 entries.