Search Results

All Results 6918
ソート
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
GZIP filter disabled by default
Issue GZIP filter is not enabled after upgrading from DXP 7.0. Environment DXP 7.0, 7.1, 7.2, 7.3, 7.4 Resolution This functionality has been disabled due to the potential security risk over HTTPS.  GZIP compression can be re-enabled with portal-ext.properties file:...
SQLSyntaxErrorException is Thrown When Liferay Starts up
Issue We set up a new environment deploying Liferay 7.4 U92 on JBoss EAP 7.4. When Liferay starts up, we observe the following error in the log: Caused by: com.liferay.portal.kernel.log.LogSanitizerException: java.sql.SQLSyntaxErrorException: (conn=78714) You have an error in your SQL...
tcp.xml file path not mapped properly in clustering setup
Issue The tcp.xml file path provided inside portal-ext.properties is unable to map it properly. The file is placed at ${Liferay_Home}/tomcat/webapps/ROOT/WEB-INF/classes/tcp.xml and the path provided inside portal-ext.properties is /tcp.xml. Environment Liferay DXP 7.2+ Resolution The...
The requested resource could not be found errors
Issue The user dashboard and profile page are not accessible on the JBoss server Steps to reproduce: 1) Set up a clean instance of Liferay 7.4 on JBoss EAP 7.4 2) login with admin (test user) 3) Navigate to the Dashboard and profile page Expected behavior: Dashboard and profile page to...
ExportImportServiceConfigurationUpgradeProcess hangs indefinitely
Issue Upgrading to DXP 74U82+ hangs in ExportImportServiceConfigurationUpgradeProcess (v1.0.2) upgrade process: INFO [main][UpgradeProcess:127] Upgrading com.liferay.exportimport.internal.upgrade.v1_0_2.ExportImportServiceConfigurationUpgradeProcess Environment DXP 7.4 U82+ DB Upgrade...
After upgrading 7.4, a new Tunnel Authentication entry is created
Issue After upgrading to 7.4 from previous versions or Updates, there is a new /api/liferay/do entry in Tunnel Authentication configuration (Control Panel > System Settings > API authentication > Tunnel Authentication). If we already have a custom configuration, after the upgrade, we can...
How to modify web content by editing database field
Issue On 7.4 there is no content field on JournalArticle table, so you can't search here this content or modify it quickly. Environment DXP 7.4 Resolution Knowing that on DXP 7.4 content field was removed from JournalArticle table, now this is generated dynamically in the method...
How to send notification based on site with groupid
Issue When having two separate sites, we want to create different notification for each, but we can't set separate notifications for different sites with the condition: groupId==<groupId of your site>. If we create "A notification" for "A site" and "B notification" for "B site", the...
How to create GraphQL request to Filter Content Structures
Issue When trying to filter Content Structure ( WebContent > Structures ), and using a wrong syntax, you might get any of the following errors: Exception while fetching data (/contentStructureStructuredContents) : null "Internal Server Error",classification": "DataFetchingException"...
"Someone may be trying to circumvent the permission checker" errors shown in the logs
Issue The following message is identified in the logs: May 10 11:28:27.159 build-3348 liferay[liferay-64c4b97d99-nvp2x] [dxp] ERROR [http-nio2-8080-exec-18][IncludeTag:128] Current URL...
Log4J 2 <Configuration> is required
Issue When system starts, following error message is showed in the log: ERROR [Start Level: Equinox Container: 6841ecc3-6984-4344-8287-86848c86a132][Log4jConfigUtil:53] Log4J 2 <Configuration> is required Environment DXP 7.4 Resolution This error denotes an incorrect syntax in...
Error updating DXP 7.4: Major upgrade finished with result failure
Issue We are updating DXP 7.4 from Update-X to Update-Y following this article https://help.liferay.com/hc/es/articles/4415761553677 Also we followed this article too: https://help.liferay.com/hc/en-us/articles/19663140037517 But when system ends the upgrade process, the following...
Multiple Nullpointer warnings while upgrading in DDMFieldUpgradeProcess
Issue Many warnings appears while upgrading Liferay DXP 7.4 from previous versions, affecting the DDMFieldUpgradeProcess (v4_1_0): INFO [main][UpgradeProcess:118] Upgrading com.liferay.dynamic.data.mapping.internal.upgrade.v4_1_0.DDMFieldUpgradeProcess WARN...
Custom Service builder cannot satisfy some dependencies when Liferay-Require-SchemaVersion is not present or incorrect
Issue Dependency issues when deploying a custom Service Builder module, because Liferay-Require-SchemaVersion is missing or not correct. Some issues are found after running ds:unsatisfied in the GoGo shell: Bundle {id: 1735, name: com.liferay.example.service, version: 1.0.0} Declarative...
Error: Could not find or load main class when upgrading Liferay version using Upgrade Tool
Issue When attempting to upgrade the Liferay version using the Upgrade Tool users are met with the following error message: "Error: Could not find or load main class [class name]", and the upgrade fails to process. Environment Liferay DXP 7.4 Resolution This error can be caused by spaces...
SOAP service list API is exposed to non-authorized guest users
Issue SOAP service list API found at http://[host]:[port]/api/axis is exposed to external guest users even with it configured to display locally only. The following property is set in portal-ext.properties: axis.servlet.hosts.allowed=127.0.0.1 Environment DXP 7.2, DXP 7.1 Resolution To...
Is JDK 17 supported by Liferay?
Issue We would like to use JDK 17 but we see that it is not listed in the Compatibility Matrix Environment Liferay DXP 7.0+ Resolution JDK 17 is not supported as of yet. However, it is already being considered The same goes for anything else that is not included in the Compatibility...
Manually Installing Liferay Connector to SAML 2.0
Issue We need to manually install and/or update the Liferay Connector to SAML 2.0. This is primarily done for security reasons, such as a Liferay bundle being firewalled off the internet.  Environment DXP 7.3 Resolution Steps to follow to manually install the Liferay Connector to SAML...
StackOverflowError related to locales during upgrade
Issue You might encounter an issue where you receive a StackOverflowError during your upgrade process, such as this: ERROR [main][ROOT:56] bundle com.liferay.portal.verify.extender:7.0.24...
Error updating DXP 7.4: Upgrade process failed or upgrade dependencies are not resolved
Issue We are updating DXP 7.4 from Update-X to Update-Y following this article https://help.liferay.com/hc/es/articles/4415761553677 But when system boots with the Update-Y installed, following message is showed in the logs: 2023-09-20 12:37:03.357 INFO  [main][UpgradeRecorder:147]...
Unable to see upload option under 'Talend' tab
Issue The user is not able to see the upload option for the file in the 'Talend tab' of the job scheduler. Steps to reproduce: Start DXP server Navigate to Control Panel > Job Scheduler Click on the add button to create a 'Job scheduler Trigger', select the Talend option, and create a...
The custom scheduler is not working after upgrading from 7.4 U62 to U90
Issue We have written a scheduler which works perfectly in 7.4 U62, but when we updated our bundle to 7.4 U90, it is not working.    Environment Liferay DXP 7.4   Resolution Due to the changes by LPS-176754, please adapt your code to make it work in 7.4 U90. Below is a guideline you can...
Error ORA-01461 and Oracle ojdbc11.jar version
Issue During upgrade to DXP 7.4 using an Oracle database, some errors happen with this pattern: ... ORA-01461: can bind a LONG value only for insert into a LONG column_ ... Environment Liferay DXP 7.4 ojdbc11.jar as database driver . Resolution We must have into account the OJDBC driver...
How to reduce disk space used by Document previews
Issue We have noticed that half of the backup size corresponds to Document previews from the Document Library. Is there a way to clean up these files and reduce the backup size? Environment Liferay DXP 7.1 Liferay DXP 7.2 Liferay DXP 7.3 Resolution You can delete the preview and...
Interval is either equal or less than 0 error during upgrade
Issue You might encounter the following error during upgrade attempt to Liferay DXP 7.4 U69+: ERROR [main][ROOT:47] bundle com.liferay.portal.scheduler:8.0.32 (654)[com.liferay.portal.scheduler.internal.SchedulerEngineHelperImpl(2334)] : The activate method has thrown an exception...
SQLException: Index column size too large. The maximum column size is 767 bytes.
Issue I used a copy of Production database (MySQL) to test upgrading from Liferay 7.4 U62 to U90. The upgrade was failed with the following error: INFO [main][UpgradeProcess:118] Upgrading...
Portal stuck on startup at 'Starting initial bundles'
Issue When trying to start Liferay, the starting process gets stuck at : 'Starting initial bundles'.  Environment Liferay DXP 7.2 with a database connected Resolution Restarting the database server and the portal should solve the issue. Checking the max number of clients on the DB side...
Users are getting different behaviors when accessing different URLs as their virtual hosts
Issue The environment is set up so that 2 different domains are acting as their virtual hosts When a user accesses one domain and logs in, and then switches to the other domain name, they find that user sessions are not carried through to each URL Environment Liferay DXP 7.3+ Resolution...
AnalyticsEventModelImpl error during upgrade via Liferay Upgrade Planner
Issue While upgrading using Liferay Upgrade Planner, the AnalyticsEventModelImpl.java class encounter some errors The following errors are readable:...
Troubleshooting WAF Blocks on Special Characters in JavaScript URLs
Issue Web Application Firewalls (WAF) or other security layers block URLs containing special characters, such as "@" and "$". This typically occurs when downloading Liferay's default JavaScript (JS) files, causing unexpected behavior or missing assets. Environment Liferay DXP (All...
OOB Category Filter widget configuration failed
Issue When updating the order of vocabularies in the Category Filter widget configurations, it fails with an error: ERROR [http-nio-8080-exec-10][render_portlet_jsp:131] null java.lang.NumberFormatException: Unable to parse 132602,132601,20140         at...
Change the trace level for code_jsp
Issue How to change the trace level for the following 'WARN', code-404: WARN  [default task-2629][code_jsp:154] {code="404", msg="Not Found", uri=/code.png Environment Liferay DXP 7.3 Resolution The user can change the trace level for 404 not found, by changing the log level of the below...
Admin will not be allowed if they doesn't contain the domain @liferay.com
Issue Users are unable to use any emails unless they have @liferay.com and are observing the "java.lang.IllegalStateException: Unable to get default company ID errors": SEVERE [http-nio-8080-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servlet.service() for servlet...
Redirect is not going to expected site page after configuring friendly URL
Issue After configuring a friendly URL for my instance Home Page, the redirect is not going to the expected site page. Environment DXP 7.2 DXP 7.3 DXP 7.4 Resolution In order to achieve the expected page redirect the Instance Home URL must be configured as well. Reference: Configuring...
How to change ReleaseInfo panel in server administration, resources tab
Issue We want to change the Release Info panel, what is shown inside the Server Administration > Resources menu Environment Any DXP 7.x Liferay version Resolution Since it would require changing the release.properties file before building Liferay, this text is not editable for Liferay...
Where are the Fix Pack Releases for Liferay DXP 7.4
Issue We are not seeing any Fix Pack releases for 7.4 recently. Can we expect FPs for 7.4 or only Service Pack? Environment DXP 7.4 Resolution Starting with Liferay DXP 7.3 SP3 and above, we switched to an Update model, which includes Liferay DXP 7.4. Updates are releases that have the...
Which folders can be cleared in the Tomcat bundle while restarting Liferay?
Issue which folders can be cleared in the Tomcat bundle before restarting Liferay? Environment Liferay DXP 7.0 - 7.4 Resolution The following folders can be cleared: osgi/state {Liferay_home}/work {tomcat_home}/temp {tomcat_home}/work, content:...
"No JSON web service action with path and method null for null" error when deploying service builder API
Issue Service builder API appears to register but isn't accessible in some environments since it cannot be found. Logs show that the service successfully deploys but not able to find the service name in /api/jsonws page. ERROR [http-nio-8080-exec-42][JSONWebServiceServiceAction:126] No...
Strange sudden shutdown of the portal running on Apache Tomcat
Issue Sudden shutdown with the following log snippet: INFO  [http-nio-8080-exec-325][SidemenuController:88] Enter in sidemenu as connected=false and isFirstConnection=false screenname=XXXXX flag=false object=null INFO [Thread-19] org.apache.coyote.AbstractProtocol.pause Pausing...
ThemeServicePreAction Null Pointer Exception at startup
Issue We always experience the following Null Pointer Exception at Liferay startup: Caused by: java.lang.NullPointerException     at com.liferay.portal.service.impl.ThemeLocalServiceImpl.getColorScheme(ThemeLocalServiceImpl.java:129) Environment DXP 7.3 Resolution To solve this issue...

該当件数: 8,806 件中 7,121 - 7,160