Search Results

All Results 6930
Sort By
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
DB2 SQL Errors during the database creation
Issue There are DB2 SQL errors during the database creation in the server startup, causing messages in the log like the following:  2019-09-19 07:38:30.286 ERROR [main][ReleaseManagerOSGiCommands:93] bundle com.liferay.portal.upgrade.impl:3.0.6...
Access denied error message is thrown in the browser with XML format of the rest API
Issue After passing the authorization in the HTTP header and while hitting the URL http://localhost:8080/o/greetings/morning, the web service responds to the request with the below error message [XML format] in the browser.  <Forbidden><message>Access denied to...
Portal has upgraded successfully and NullPointerException is thrown with the server startup
Issue Successfully upgraded the Liferay portal from 6.2EE to DXP 7.1 GA but the server is not started and thrown the NPE Null pointer Exception: 2019-09-13 01:11:59.750 ERROR [http-nio-8080-exec-1][MainServlet:1225] com.liferay.portal.kernel.events.ActionException:...
"Redirect URL is not allowed" Log Errors and Redirect Issues
Issue There are traces in Liferay's logs resembling this: 2019-08-27 08:46:42.641 WARN [http-nio-8080-exec-4][PortalImpl:1003] Redirect URL .... is not allowed Additionally, some other issues appear at the same time: Some buttons in the Control Panel don't work (for instance, the 'Add'...
EXT Plugin not deploying
Issue EXT Plugin not deploying correctly through the methods presented in the documentation: Deploying an Ext Plugin Environment Liferay DXP 7.1 Resolution Deploy the EXT Plugin to marketplace/override folder Remove any version number present in the .jar name Delete the contents of...
LCS Activation Page redirect
Issue The portal redirects automatically to the LCS Activation Page even with activation tokens deployed. Environment Liferay DXP 7.0+ Resolution  Regenerate the LCS tokens, but with "Liferay Instance Activation" option on 'Yes'. Once the tokens are regenerated with that option set to...
Calendar Event invitation mail is sent to the user before the approval of event
Issue If the workflow is applied for the Calendar Event, the user who is invited to that particular event gets an email invitation even before the approver approves the event. Environment Liferay DXP 7.0 Resolution The observed behavior is a known issue and is fixed in...
Retrieving custom cache entity fails with error
Issue The custom cache entity we introduced to Liferay is inaccessible. We configured our custom cache in override-liferay-multi-vm-clustered.xml. When trying to access the custom cache entity from scripting console by:...
Tomcat trimSpaces feature breaks Liferay styling and functionalities
Issue When setting trimSpaces in tomcat-9.0.6/conf/web.xml: <init-param> <param-name>trimSpaces</param-name> <param-value>true</param-value> </init-param> some functionalities on the Liferay User Interface (buttons, styling) may be broken. Environment Portal 6.1+ Liferay DXP 7.0+...
How to remove unnecessary parts from the URL / shorten URL / make URL friendlier
Issue We would like to remove the web/guest part of the URL, to shorten it e.g. http://www.example.com/web/guest/home-> http://www.example.com/home  Environment Liferay Portal 6.2 Liferay DXP 7.0-7.4 Resolution The default public Site base URL is...
External images inside OpenOffice/LibreOffice document are not resolved when converted to PDF
Issue Upload to Document Library a new OpenOffice document with external link to image. Export the document to PDF. The document is converted to PDF but the image is blank. Environment Liferay DXP 7.0, 7.1, 7.2 with OpenOffice installed and running as external service. Resolution Go to...
Audience Targeting is deployed but unavailable
Issue After deploying and restarting, Audience Targeting is not available in site's Configuration > Audience Targeting. Tables corresponding to Audience Targeting are not created. Environment Liferay DXP 7.0, 7.1 Resolution Look out for a file...
Updating the Time Zone of All Users in your Instance
Introduction Liferay supports localization by language, time zone, and more. While Liferay has a default configuration for time zones, you can set the platform to use any standard time. After installing Liferay and creating all users, a company noticed that the instance and all users are...
DXP 7.2 Upgrade Reference Guide
An upgrade to Liferay DXP 7.2 gives you access to the latest Liferay technology, complete with all of the newest features, and the assurance of continued support for your Liferay environment. Our Subscription Services Team recognizes that an upgrade often requires a significant...
How to get the total number of documents once migrated from File System to DB Store?
Issue If the data is moved from the File System to DB Store, then how to get the number of documents from the portal. Environment Liferay DXP 7.0 Resolution When DB Store is used as a repository, the files are stored in two tables 'dlfileentry' and 'dlcontent' tables. The "dlfileentry"...
Page not found (404) redirects to the 'default' (Guest) web site
Issue When an incorrect URL is hit on the portal, the "The requested resource could not be found" error or Page not found error redirects to the default site and not to that particular site. Environment Liferay DXP 7.0 Resolution The observed behaviour is an intended behaviour of...
Control Panel App Manager not showing
Issue The App Manager section in the control panel is missing. Environment Liferay DXP 7.1, 7.2 Resolution Try this list of steps: Stop the application server. Delete the contents of the directory $LIFERAY_HOME/osgi/state/. Start the application server. If that doesn't work, try: Go to...
Setting different landing pages on different cluster nodes upon session timeout
Issue The users have to be redirected to different pages - depending on the nodes -, when the sessions expire. A possible use case: One of the Application Servers is an admin server, thus the admins need to be redirected to a different URL (the admin site), than the regular ones, upon...
How can I disable Liferay's xml log file?
Issue In {Liferay_Home}/log folder, we can see two different files as below:      liferay.2019-08-25.log      liferay.2019-08-25.xml We only want "liferay.2019-08-25.log" file and need to disable "xml" file. Environment Liferay DXP 7.0 Liferay DXP 7.1 Liferay DXP 7.2 Liferay DXP 7.3...
How to resolve AnnotationExceptions encountered during startup when updating 7.0 to de-67+ while using WebSphere
Issue Using WebSphere FP 11 as our application server, we are unable to start up a 7.0 deployment after patching to de-67, and are receiving an AnnotationException in the log, as follows: Annotation processing failed with the following error:...

Showing 7,901 to 7,920 of 8,825 entries.