Search Results

All Results 6930
ソート
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Change the Sitemap format in Liferay DXP
Issue The default Sitemap format in Liferay DXP is "Sitemap Index". For example, accessing http://localhost:8080/sitemap.xml will return the following content. How do I change the default format to use Sitemap instead?...
Resolving errors when using Liferay JSON Web Service to do the searching
Issue When invoking Liferay JSON Web Service to do the searching, you may encounter errors like the following: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.SQLGrammarException: could not execute query user lacks privilege or object not found:...
How to hide the title of a portlet on DXP
Issue On Liferay Portal 6.2 EE, if one would like to make the title of a portlet non-visible, an easy way is to set an empty string ('') as title. Although, on DXP (7.0 and above) it is no longer possible, hence if the title is set with an empty value, the portal automatically replaces...
How can I keep a web page out of Google's crawler?
Issue I don't want some pages to be crawled by Google and display in the search result.  Environment DXP 7.0, DXP 7.1, DXP 7.2 Resolution You can prevent a page from appearing in Google Search by including a noindex meta tag in the page's HTML code, or by returning a 'noindex' header in...
Should we reindex all search indexes on a regular basis?
Issue Should we reindex all search indexes as a regular maintenance task? If so, how often should we complete it? Environment Liferay DXP 7.0 Liferay DXP 7.1 Liferay DXP 7.2 Resolution It is not necessary to perform full or partial reindex on a regular basis, as reindexing is not a...
LDAP users are unable to log in(Caused by: java.net.SocketException: Connection reset)
Issue If the LDAP is configured and when the LDAP users are trying to log in, authentication fails and started getting the following error in the server console. ERROR [liferay/scheduler_dispatch-4][PortalLDAPImporterImpl:717] Unable to import user CN=makansal:...
How to resolve Dev Studio "Could not create DXP download token" installation errors
Issue When trying to install Liferay Dev Studio, I get a UI error that states "Problem running post-install step. Installation may not complete correctly. Could not create DXP download token," and no files are installed.  I am connected to the internet and I've verified the username and...
Can I change the default Control Menu position to closed?
Issue Is there a setting or configuration to have the left side Control Menu hidden by default when a user logs in on our site? Environment DXP 7.0 DXP 7.1 DXP 7.2 Resolution There are no settings or configurations present to change the default Control Menu position. However, it is...
Are Fix Packs cumulative?
Issue I would like to install the latest Fix Pack. Do I need to install all previous ones as well? Environment Liferay Portal 6.2 Liferay DXP 7.0+ Resolution All Fix Packs are cumulative here at Liferay. This means that the latest Fix Pack contains all of the updates of the previous Fix...
Conversion process fails in Adaptive Media
Issue When I try to convert my images in Adaptive Media, the whole conversion process fails I see this message in the console: Caused by: java.lang.IllegalArgumentException: Unknown image type 0 at java.awt.image.BufferedImage.<init>(BufferedImage.java:501) at...
LPKGVerifyException is reported when upgrading to LCS client 6.0.0
Issue When upgrading to LCS client 6.0.0, the following error is reported: 12-Sep-2019 06:06:57.072 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.listenerStart Exception sending context initialized event to listener instance of class...
Incorrect Metadata in Document & Media
Issue While uploading a file with .pptx extension in Document and Media, the "Automatically Extracted Metadata" takes it as "Content Type application/zip". Environment Liferay DXP 7.0 Resolution The observed behavior is resolved and fixed in liferay-fix-pack-de-67 and above. Installing...
Search Result Widget does not populate Products associated with Category Content
Issue When utilizing a Category Display Widget and Search Result Widget on a page in Commerce 2.0.1, navigating to a Commerce Category at the Site level should populate Products in the Search Results Widget (i.e. localhost:8080/web/[site-name]/g/brake-system). Reported to be working in...
Unable to handle SAML Request
Issue After enabling the SAML, when the user is trying to log in, authentication failed with the following message in UI and in Server console. UI: "Unable to handle SAML Request" Server Console:  ERROR [http-nio-443-exec-81][BaseSamlStrutsAction:54]...
Method to diff two Liferay Fix Packs
Issue How can I find the difference between two fix pack versions? Is there a method to diff fix packs? Environment DXP 7.2    DXP 7.1    DXP 7.0 Portal 6.2 Resolution Quick method: Liferay provides an Online Comparison Tool for DXP Releases Manual method: In this example guide, we will...
Authentication through LDAP when SAML is enabled
Issue Liferay has to authenticate the user through SAML as well as LDAP when SAML is enabled Environment Liferay Portal 6.2 Liferay DXP 7.0 Liferay DXP 7.1 Resolution Authenticating users from LDAP when the SAML is enabled is not currently available as an out of the box feature in...
How to simulate a remote staging environment with one portal
Issue To simulate a staging environment with just one portal instance. Environment Portal 6.2 DXP 7.0 DXP 7.1 DXP 7.2 DXP 7.3 Resolution Just need to configure in the remote staging configuration page, the site id of that you want to be as remote site. It could be even from the same...
Change of context between themes is not working as expected
Issue Changing pages using the navigation from Liferay won’t actually trigger a reload in the page. Instead, the content that is being displayed will change, and some of the resources and imports won’t actually be loaded again, what gives Liferay a big boost in terms of load. This is the...
LDAP users are able to login with Default User Password
Issue Users from LDAP are able to login with the value which is defined in "Default User Password" field under the LDAP import/export settings. Environment Liferay DXP 7.0 Resolution Liferay will allow the LDAP users to login using the defined value in the "Default User Password" field...
How can I create custom form rules?
Issue I would like to create a custom rule for our forms Could you please suggest if rules can be created by custom development? Could not find any article related to that. Apparently there is some API for doing this In Liferay DXP 7.1 Datasheet, Under Forms and Workflows --> Conditional...

該当件数: 8,825 件中 5,781 - 5,800