Search Results

All Results 6930
Sort By
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
パスワードの暗号化を無効にする
事象/ユースケース 開発環境にてパスワードの暗号化を無効にしたい場合があります。 解決策/提案 passwords.encryption.algorithmプロパティでパスワードの暗号化方法を指定します。NONEに設定することでパスワードが暗号化されません、テキストとして保存されます。 # # パスワードを暗号化するには、以下の暗号化アルゴリズムを設定してください。 デフォルトのアルゴリズムは、PBKDF2WithHmacSHA1 / 160/128000で、128,000ラウンドを使用して160ビットのハッシュを生成します。 # #...
メールアドレスにおける大文字の制限
  メールアドレスにおける大文字の制限   詳細 Liferayでは、ユーザーのメールアドレスに大文字を入力しても、小文字へ変換されたうえで保存される設計となっています。 制限の理由 データベースの種類やバージョンによっては、大文字小文字を区別しないものがあります。 Liferayは、メールアドレスで扱う文字列を小文字に統一することで、 大文字小文字を区別しないデータベースにも対応できる設計になっています。, knowledgeArticleType: reference, legacy: true, name: メールアドレスにおける大文字の制限,...
スクリーン名について(Liferay DXP)
背景: Liferayのデフォルト設定では使用できないスクリーン名があります。 その制限の回避方法をご紹介します。 詳細: 使用不可能な文字 デフォルトのLiferayで、スクリーン名に使用出来ない文字や文字列は以下の通りです: 「半角英数字(0-9, a-z)」、「-(ハイフン)」、「.(ドット)」、「_(アンダースコア)」以外の文字列  ※半角大文字で入力した場合でも全て小文字に変換されます @を含む文字列 半角数字のみの文字列 75文字より多い文字列 admin.reserved.screen.namesプロパティに指定された文字列  ...
ページ毎に異なるブックマークを表示する
事象/ユースケース サイト内に管理されているブックマークでも、ページ毎に異なるブックマークを表示したい 解決策/提案 ブックマークポートレットのスコープを設定することによって、同じサイトのページでも異なるブックマークを表示できます。 当該サイトのブックマーク管理画面から、ブックマークを多少追加 Page1を作成して、 ブックマークポートレットを配置 追加したブックマークが表示することを確認 Page2を作成して、ブックマークポートレットを配置 →Page1と同様に既存ブックマークが表示されます ブックマークポートレットの右上のオプションメニューから「設定」を選択...
Liferayのドキュメントルートを変更する方法(プロキシパスの設定)
事象/ユースケース Liferay運用の際にプロキシを経由して、https://example.com/ ではなく https://example.com/liferay/ のようなパスで運用する必要があります。 解決策/提案 portal.proxy.pathでプロキシパスを指定します。 https://example.com/liferay/で運用する場合、_[liferay_home]/portal-ext.properties_に以下の設定を加えます。 # # Set this property if the application server is...
OpenType Layout tablesエラーの対処法
事象/ユースケース 以下のような「OpenType Layout tables used in font <フォント名> are not implemented in PDFBox and will be ignored」がログに出ています。 07:27:14,844 ERROR [liferay/background_task-1][PDCIDFontType2:211] OpenType Layout tables used in font ArialMT are not implemented in PDFBox and will be ignored...
フォームを複製する方法
事象/ユースケース 新規フォームをゼロから作成より、既存のフォームを複製して調整した方が効率的に良い場合があります。 解決策/提案 エクスポート・インポート機能をご利用できます。 フォームが既に存在する状態 画面右上のオプションメニューから「エクスポート/インポート」を選択 「エクスポート>新規エクスポートプロセス」を選択 複製したいフォームが選択されるように、「コンテンツ」セクションから適切な範囲を設定 「 エクスポート」をクリック 生成された.larファイルをダウンロード 「インポート」タブに移動 「ファイルを選択」ボタンをクリック ダウンロードしたファイルを選択...
ドキュメント管理のチェックアウト期間を調整する
事象/ユースケース ドキュメント管理のチェックアウト機能でチェックアウトを行った際に、ロックの制限時間が1日を過ぎれば解除されます。 解決策/提案 以下のプロパティを設定することで、フォルダとファイルのロック時間をそれぞれ調整します。(単位:ミリ秒) # # Locks for document library folders should expire after 1 day. # lock.expiration.time.com.liferay.document.library.kernel.model.DLFolder=86400000 # # Locks for...
LiferayでのSAML設定方法
SSOとは、ユーザーが複数のサイト間で都度パスワード認証をする手間を省くため、サーバやアプリケーション、ネットワークに接続する際のサインオンを一度の手続きで行い、複数アプリケーションやサーバに接続できるようにするる仕組みです。SAMLはSSOの一つです。SAML 2.0とは、ユーザの情報を含むトークンを利用して、SAMLオーソリティー(アイデンティティープロバイダー)とSAML消費者(サービスプロバイダー)とコミュニケーションするXMLプロトコルです。 詳細 1) アイデンティティープロバイダーの作成  目的:1台のLiferayはIdPとして設定と運用...
マーケットプレイスからアプリを入手する
マーケットプレイスからアプリを入手する 詳細 手順 マーケットプレイスにログイン マーケットプレイスで入手したいアプリ(例:Liferay Connected Services Client)のページへアクセス 「無料」又は「購入」をクリック 「この支払い対象のプロジェクトを選択」で任意のプロジェクトを選択 ※無料アプリに請求は発生しません ※適当なプロジェクトが分からない場合は「個人使用のみ」を選択します 「私はエンドユーザ使用許諾契約 と 免責条項を読んで合意しました。」にチェックを入れ「購入」をクリック 「購入済みを見る」をクリック...
プロダクトメニューから任意の項目を外す方法
Liferay DXPのプロダクトメニューにはデフォルトで多くの項目が表示されますが、運用要件によってはすべて表示させる必要はなく、任意の項目を外したくなる場合があるかもしれません。 この記事では、プロダクトメニューから任意の項目を非表示にする方法を説明します。 前提 Liferay DXP SP6のTomcatバンドルを起動している。 Resolution 「自分のアカウント」を非表示にする コントロールパネル > ユーザ > ロールへ移動 User > 権限の定義をクリック ユーザー > アカウント設定を展開 非表示にしたい項目で以下を繰り返す:...
Liferayのログに出力される時間のタイムゾーンを変更する方法
Liferayのログに出力される時間のタイムゾーンを変更する方法 詳細 ※Tomcatのログに出力される時間のタイムゾーンを変更する方法ではありません 設定と確認の手順 アプリケーションサーバが起動している場合、停止する 「$TOMCAT_HOME/webapps/ROOT/WEB-INF/lib/portal-impl.jar」を解凍して、中の「META-INF/portal-log4j.xml」を「$TOMCAT_HOME/webapps/ROOT/WEB-INF/classes/META-INF/」直下にコピーする...
DXPで「ldap.import.create.role.per.group」を使用する方法
DXPでldap.import.create.role.per.groupを使用する方法 Liferay 6.2には、LDAPのグループをインポートした際に同名のロールを自動的に作成するためのプロパティldap.import.create.role.per.groupがあります。DXPではportal-ext.propertiesでの設定はできなくなり、代わりにGUIから設定する必要があります。 GUIからの設定方法は以下の2つがあります。 解決策 インスタンス毎に設定する方法 「コントロールパネル>設定>インスタンス設定」へ移動 「認証」パネルの「LDAP」をクリック...
DXPのAuditログをファイルへ出力する方法
DXPのAuditログをファイルへ出力する方法 詳細 留意点 この設定はDXP 7.0 Fix Pack 12以上で有効です 要件例 Auditログを、データベーステーブルではなくログファイルとして出力する 一日おきにログローテーションする 設定手順 「コントロールパネル>設定>システム設定>基本設定>Logging Message Audit Message Processor」へ移動 「Enabled」にチェックを入れ、任意の「Log message format(CSV / JSON)」を選択し、更新 アプリケーションサーバーを停止...
Liferay DXPのインストール
インストールのため必要な準備が整った際、Liferay DXPのインストールを開始できます。インストールを完了させるにはバンドルが最も簡単な方法なので、下記のインストール手順はすべて、バンドルがインストールされていることを想定しています。   Liferay Home Liferay DXPバンドルには、アプリケーションサーバーとは関係なく、同一のフォルダ構造が含まれています。最上位のフォルダは、Liferay DXPのリリースに対して名前が付けられます。このフォルダの名称は Liferay Home...
Help Centerチケット添付用のパッチレベルファイルを取得する
詳細 パッチレベルファイルはサポートエンジニアがLiferayの稼働環境構成を把握するうえで非常に重要なファイルです。このページではそのパッチレベルファイルの取得手順を説明します。 Resolution 前提 最新のサービスパックの「Bundled with Tomcat」を任意のディレクトリへ展開済みとする 以下、展開済みのライフレイのディレクトリを「<LIFERAY_HOME>」と記する 取得の流れ コマンドラインで<LIFERAY_HOME>/patching-tool/ディレクトリへ移動 ./patching-tool.sh...
Liferay DXP Agent Fails to Start on Jakarta (Tomcat 10) Images with javax.annotation Error
Issue When using a Liferay DXP instance deployed on a Jakarta-based image (e.g., Tomcat 10), the liferay-dxp-agent bundle may fail to start. The logs will show an org.osgi.framework.BundleException error related to an unresolved package import. A key part of the error message will look...
How does Let's Encrypt validate custom domains to create their certificate?
Issue How does Let's Encrypt validate custom domains to create their certificate? Environment Liferay Cloud Resolution Custom domains undergo a challenge before certificates can be properly issued. If the challenge completes successfully, a multidomain certificate is generated for all...
Will page comments be deleted after time or when reaching a storage limit?
Issue Are there any settings that regulate retention of comments? In other words, how many comments can be stored for a page before they are deleted automatically? Environment DXP 7.2 Resolution There is no automated 'housekeeping' function that deletes old comments or any maximum limit...
How do you edit robots.txt for virtual host public pages?
Issue We are trying to edit the robots.txt file through public pages, but we are getting the following message: 'Please set the virtual host before you set the robots.txt'. We are using one instance with two sites and have defined in apache two servers with the appropriate re-directions,...

Showing 6,501 to 6,520 of 8,829 entries.