Search Results

All Results 6916
Sort By
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Audit logs for site page deletion
Issue Need to get audit logs for site page deletion/ update. Environment Liferay DXP 7.0 Liferay DXP 7.1 Liferay DXP 7.2 Liferay DXP 7.3 Resolution There are no OOTB configuration available for getting the Audit logs directly. However, user can get these audit logs by adding a custom...
Gradle build without internet connection
Issue How to build the Gradle workspace without an internet connection? Steps to run the gradlew command using offline mode Environment Liferay DXP Resolution We have improved the offline support in the most recent release of the DevStudio, however, all of our build tools (Gradle or...
The Layout table still contains database references for removed sites
Issue Not all references to a deleted site are removed since entries in the Layout table that had the site's groupId are still present after the deletion is complete. Steps to Reproduce 1. Start a clean DXP 7.3 instance connected to a database (such as MySQL) 2. Create a test site...
Conflict loading libraries from the global classpath(tomcat-<version>/lib/ext/)
Issue Loading the libraries from the global classpath is conflicting with one of the Liferay's internal module Caused by: java.lang.ClassNotFoundException: org.apache.commons.compress.archivers.zip.ZipFile         at java.net.URLClassLoader.findClass(URLClassLoader.java:382)...
Alternative for browser native dialogs when Liferay is rendered in cross-domain iframes
Issue Is there a roadmap for Liferay to deal with Chrome's decision to remove JS dialogs from cross-origin Iframes? Since this can create issues such as using the Control Panel when Liferay is using one of those dialogs (https://www.chromestatus.com/feature/5148698084376576) Let's...
Specifications API is not supporting Upsert operations
Issue Users are unable to add translations for title/labels in Specification API. Steps to reproduce: 1. POST a specification by using the Specification API endpoint (/o/headless-commerce-admin-catalog/v1.0/specifications) { "key": "demo-abc", "title": { "en_US": "Demo Specification ABC"...
Unable to add Products with Tags via headless API
Issue Steps to reproduce: 1. Create a product using POST /v1.0/products (Request is attached). 2. Execute the request and check the response. 3. Tags are showing blank and on Product UI, tags are not generated. Expected Behavior: Tags must be created while creating the product with tags...
Unable to add Products with Specifications via headless API
Issue When a product is created with specifications, the 200 response code is received. But, on UI product is not visible. Steps to reproduce: 1. Create a product by using the POST /v1.0/products (Request is attached) 2. Click on Execute. 3. Check the created product on UI. 4. Product is...
When the data for 'from address' and 'from name' are more than 50 characters, custom calendar notification templates cannot be saved
Issue The notification template is not being saved Steps to reproduce: 1. Add a 'Calendar' portlet to page 2. Navigate to Calendar settings 3. Navigate to notificationtemplates tab 4. Edit 'from address' and 'from name' so that those fields have more than 50 characters together. For...
After installing a new portal with an AdvancedFileSystemStore document_library, the images aren't shown
Issue After migrating, upgrading or installing a new portal with an existing database and document library folder using the AdvancedFileSystemStore the images and documents aren't accessible. Environment Liferay DXP (any version) Resolution After installing a new portal and copying the...
The DXP/Portal WAR's shielded-container-lib/ directory to load libraries
Issue Shielded container library in DXP 7.4 over global classpath(tomcat-<version>/lib/ext/ directory to load libraries globally) Environment Liferay DXP 7.4 Resolution The DXP/Portal WAR's shielded container-lib folder includes DB drivers and other JARs as a convenience. You can still...
Heat mapping functionality in Liferay Analytics Cloud
Issue With Heat Mapping as part of Liferay Analytics, it would be great to have a one-stop-shop experience. Heatmapping functionality that would allow consumers to see what areas of each page are used most by users Environment Liferay Analytics Cloud Resolution Liferay Analytics Cloud...
Can I change the CPU and Memory usage alert metrics?
Note: please note that Liferay has renamed its Liferay Experience Could offerings to Liferay SaaS (formerly LXC) and Liferay PaaS (formerly LXC-SM). Issue Is there any way to change the default metric value of CPU and Memory usage to a custom value? Environment Liferay PaaS Resolution...
Liferay image fails to start with a javax.servlet.ServletException
Issue My Liferay image is failing to start with the default settings. The following message is thrown in the logs: javax.servlet.ServletException: A servlet matching the filter (servlet.init.private=false)(servlet.type=friendly-url) is unavailable Environment DXP 7.4 Resolution A fix for...
Using $dateTool.toDate in a Velocity template does not return any date
Issue In a Velocity template, trying to get a date using dateTool.toDate does not work as expected when using a locale different from default one. As an example, if under those conditions we have a Velocity template with below code  #set ($dateStr = $dateTool.toDate( "EEE, dd MMM yyyy...
Liferay related fields that can be added in Jboss access log
Issue How to add the access-log pattern that includes Liferay related fields in the access log? Environment JBoss 6.x JBoss 7.x Liferay DXP Resolution To enable the access logs, you may follow the documentation listed in the `Additional Information` section below, however, to add Liferay...
Adding all locales is exceeding the maximum characters
Issue The below error is observed when Liferay DXP 7.4 is started with this property...
Files in the document_library folder are owned by the root user
Issue After executing the portal with the Linux root superuser, some files and folders in the $LIFERAY_HOME/data/document_library folder are now owned by the root user and can't be accessed by the portal when running it with the original portal user (e.g. liferay). Environment Any...
(IX_228562AD) violated on Server restart caused by a DuplicateLockException
Issue Unique constraint (IX_228562AD) violated on Server restart. It could be shown as an ERROR log message in JDBCExceptionReporter class and an INFO log error in BackgroundTaskMessageListener class. 2022-04-20 11:32:25.855 ERROR [liferay/background_task-3][JDBCExceptionReporter:234]...
Page .lar exports are failing to be imported due to a "DuplicateVocabularyException: A category vocabulary with the name topic already" exists
Issue Page .lar exports from one 7.3 environment are currently failing to be imported in a separate 7.3 environment due to the following error:  DuplicateVocabularyException: A category vocabulary with the name topic already exists Environment Liferay DXP 7.3  Resolution Open a Help...

Showing 7,401 to 7,420 of 8,802 entries.