Search Results

All Results 6930
ソート
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
What is a Vanilla Bundle?
Issue What does it mean to test with a Vanilla Bundle? Environment DXP 7.0 | DXP 7.1 | DXP 7.2 | DXP 7.3 | DXP 7.4 Resolution Firstly, it may also be referred to as a clean, blank, or fresh bundle.  In Liferay Support we often use this term to describe a base-level instance of DXP. The...
Is there a Tool to Whitelist Specific Regex in OSGi?
Issue Is it possible to enable a whitelisting of specific regex for OSGi module configurations? Environment DXP 7.2 Resolution There are not any out of the box tools regarding whitelisting specific regex for OSGi. The closest we have is an OSGi blacklist that prevents deployed modules...
java.lang.RuntimeException: java.lang.NumberFormatException: For input string: "" after upgrading to a new 7.4 Update version
Issue After upgrading from DXP 7.4 Update 55 to Update 58, exception java.lang.RuntimeException: java.lang.NumberFormatException: For input string: "" is thrown during Liferay startup 2023-02-28 12:15:02.136 ERROR [main][DBUpgrader:79] null java.lang.RuntimeException:...
Soft Delete for Sites and Pages
Issue When deleting pages and sites, they are permanently deleted, making the process irreversible. Is there any parameters where I can configure this exclusion with the possibility of reverting?  Environment All environments Resolution Unfortunately, currently there isn't a feature OOTB...
The webapps folder is re-created
Issue We have moved the $CATALINA_HOME/webapps folder to a separate partition. We have updated the appBase attribute to point to the new directory, and have deleted the original webapps folder under $CATALINA_HOME. We are able to restart the application and it is working as expected....
Virtual instance can’t be accessed after backup recovery
Note: please note that Liferay has renamed its Liferay Experience Could offerings to Liferay SaaS (formerly LXC) and Liferay PaaS (formerly LXC-SM). Issue After performing a backup restore from one environment to another (e.g. from PRD to UAT) the virtual instances previously created...
Task scheduler extending BaseMessageListener not working after restart
Issue A task scheduler component extending BaseMessageListener works correctly when deployed to Liferay. When the server is rebooted, though, the task is not registered and it won't be executed. Environment Liferay DXP 7.4, 7.3 Resolution A task scheduler usually makes use of a...
Is there a way to check the jobs that are being executed and that are in the queue?
Issue Is it possible to check the jobs that are being executed and that are in the queue in the UI? Environment Liferay DXP 7.4.X Resolution As of Liferay DXP 7.4, the UI has a Job Scheduler option where you can view/manage Jobs: Control Panel -> CONFIGURATION > Job Scheduler > Sheduled...
The Layout Page Template Entry Widget Page Template Name could not be imported
Issue A page template cannot be imported Steps to Reproduce: 1) Create a site named 'Test Site 1' 2) In Test Site 1, Design -> Page Templates -> Page Templates, create a new set. 3) Under the set, create a widget page template. 4) Export the site. 5) Create another site and import Test...
Unable to create message factory for SOAP
Issue When attempting to implement a soap client to call remote soap services, the following error occurred: Caused by: javax.xml.soap.SOAPException: Unable to create message factory for SOAP: Unable to create SAAJ meta-factory: Provider...
ConnectionPoolTimeoutException: Timeout waiting for connection from pool exception when using HttpUtil.URLtoString method from a custom development
Issue We are using Liferay URLtoString  method from  com.liferay.portal.kernel.util.HttpUtil in our custom development to call an external web service We are getting ConnectionPoolTimeoutException: Timeout waiting for connection from pool  exception when our custom development calls the...
The exception "java.lang.NoClassDefFoundError: aries/base/Parameter" occurs after upgrading from 7.3 GA1 to 7.3 Update 21
Issue I am seeing this error after upgrading Liferay 7.3 GA1 to 7.3 Update 21 with WebLogic 12c R2 java.lang.NoClassDefFoundError: aries/base/Parameter   Environment DXP 7.3   Resolution Update the portal property module.framework.properties.org.osgi.framework.bootdelegation with the two...
Unable to sort the entries by using the External Reference Code
Issue It's not possible to sort the entries by using the External Reference Code Steps to Reproduce: 1) Create an object 2) Create Field text 3) Navigate to View tab > Create a Custom View > Mark as default 4) Navigate to the View Builder tab > Add all columns 5) Now, go to Default Sort...
The mandatory field Language of object is empty and is possible to save the changes
Issue Why it is possible to save the mandatory Language field without any value? Steps to reproduce: 1) Navigate to Control Panel > Object > Objects 2) Create a custom Object 3) Create a Text field 4) View this field 5) Change the type from Text to any type not related to the text (e.g....
Receiving NoSuchMethodError on DLAppService.AddFileEntry function
Issue Using the following method, to add file entries to the portal, at deployment: addFileEntry(   String externalReferenceCode, long repositoryId, long folderId,                 String sourceFileName, String mimeType, String title,                 String description, String changeLog,...
WYSIWYG editor in custom jsp is not working
Issue Adding a WYSIWYG editor to a portlet by following this document is not working with the below error 2023-01-02 10:04:42.080 ERROR [http-nio-8080-exec-6][IncludeTag:128] Current URL /announcements generates exception: java.lang.UnsupportedOperationException: Requires 3.0 opt-in...
How can I get information about my Liferay license?
Issue Is there a way to get information about my Liferay license in the UI? Environment Liferay DXP 7.0+ Resolution On Liferay 7.0, 7.1, 7.2: Go to Control Panel > Apps > License Manager On Liferay 7.3, 7.4: Go to Menu > Control Panel > MARKETPLACE > License Manager Additional...
com.liferay.petra.process.ProcessException: java.io.IOException: Broken pipe error during indexation process
Issue We have configured the text extraction functionality in an external process using the configuration: text.extraction.fork.process.enabled=true text.extraction.fork.process.mime.types=application/x-tika-ooxml,application/pdf But when we try to execute a reindexation process, the...
Unable to define the searchable option with new objects fields
Issue Unable to configure the searchable options of new fields added to an object after it has been published. Steps to reproduce: Create an object: 'Pets' Add a new field: 'petName' (Text, indexed as text) Publish the Pets object definition Try to add a new field: description Observed...
Unable to Publish Object Definition Relationships after Importing
Issue The user is not able to publish Object Definition relationships after importing them Steps to reproduce: 1) Navigate to the Applications Menu -> Control Panel -> Objects 2) Import one Object Definition with a relationship 3) Public first Object Definition 4) Public the second one...

該当件数: 8,829 件中 7,321 - 7,340