Search Results

All Results 6918
ソート
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
Unable to add a document from Control Panel-> Document and Media.
Issue Unable to upload any document from the Content and Data-> Document and Media-> Add (option). The Add option becomes unresponsive.  This behavior is only observed whenever the server is started from Liferay Developer Studio(LDS). Environment Liferay DXP 7.2 Resolution When the...
Elasticsearch killed by Linux OOM Killer
Issue Linux Out of Memory Killer stops the Elasticsearch Java process OOM Killer is killing ES Environment DXP 7.2      DXP 7.1      DXP 7.0 Resolution Set a limit on how much memory Elasticsearch can use outside the heap 1. Elasticsearch can consume memory outside of the JVM heap 2....
Publish two different Contents by creating only one Web Content
Issue How to display two different types of content through the same web content? Environment Liferay DXP 7.2 Resolution It is possible to use the same Web Content on different pages using the different layout/template. Please refer the below example for the same: a) Create a Structure...
Primefaces: commandButton ajax="false" will not work with p:dataExporter and p:fileDownload
Issue When using the Primefaces <p:commandButton ajax="false" /> with p:dataExporter and p:fileDownload, the page will not render properly, there will be visual issues. Environment Liferay DXP 7.0+ Resolution When using p:dataExporter and p:fileDownload in portlets, it is a best practice...
Soy taglib for ColorPicker no longer works as of 7.1 with fix pack dxp-13-7110
Issue From 7.1 with fix pack dxp-13-7110+ , using Soy taglib to create a ColorPicker, similar to this: <%@page import="java.util.HashMap"%> <%@page import="java.util.Map"%> <%@ include file="/init.jsp" %> <%@ taglib uri="http://liferay.com/tld/soy" prefix="soy" %> <p>...
OrderID license validation failed deactivating my server
Issue Previously it was possible to activate a Liferay Portal server using an OrderID, this activation method is now deprecated and the web address that the Portal will attempt to communicate with is no longer valid. This has caused the Portal to be unusable Environment Liferay Portal...
Script loading issue is occurring in the sub versions of Internet Explorer 11 browser
Issue The script loading issue is occurring in some systems but using the same Internet Explorer 11 subversions, its working fine in other systems. Environment Liferay DXP 7.2 Resolution Removing some of the third party scripts [For example, nicescroll.js] resolves the script loading...
Heavy database queries involving DLFileEntry table
Issue In some cases you could find that your database is spending a lot of time procesing this query: SELECT fileEntryId, groupId, companyId, userId, userName, createDate, modifiedDate, classNameId, classPK, repositoryId, folderId, treePath, name, extension, mimeType, title, description,...
Canonical tags are not language specific
Issue I start Liferay I create a new site with a new page I sign out I navigate to the newly created page and inspect the HTML: <link href="http://localhost:8080/sitename" rel="canonical"> I switch to another language (eg: German) by navigating to http://localhost:8080/de/sitename I...
DXP 7.2 Service Pack 1 (SP1)/Fix Pack 2 (FP2) requires Elastisearch 6.2 or higher due to InvalidTypeNameException error on startup
Issue When DXP 7.2 SP1+/FP2+ is configured with Elasticsearch 6.0 or 6.1, the following error occurs on startup: Oct 22 13:42:10.417 build-14 [liferay-847b9fcf98-jmbds] [dxp] ERROR [main][IndexSynchronizationPortalInitializedListener:93] bundle...
Liferay's OpenID Connect implementation and Single Logout
Issue Does Liferay's OpenID Connect implementation support Single Logout? Environment Liferay DXP 7.1/7.2 Resolution Liferay's current OpenID Connect (OIDC) integration only implements parts of the Final specifications, specifically "Core" and "Discovery". While single-logout (SLO)...
Using one user's JSessionID any logged in user can access the respective user's session
Issue One user's session is accessed by knowing the respective user's JSessionID. Steps for reference: 1) 2 users (say: User A and User B) 2) User "A" logs-in to the system 3) Now, user "A" has one Jession ID(0D13262EDECBA19E93D5A753FC34E03A) and shares his JSessionID to user "B" 4)...
Not able to search document with Title after Applying Workflow
Issue After applying workflow in the Web Content, try to search the same content in "My Workflow Tasks". The search shows no result. Environment Liferay DXP 7.0 Liferay DXP 7.1 Liferay DXP 7.2 Resolution The observed behavior is a known issue and is fixed For Liferay DXP 7.0...
Multi Language friendly URL keyword conflict
Issue While updating Multi-Language friendly URL for the Hindi language as "/hi_IN" for the new page below error is observed: "Please enter a friendly URL that does not conflict with the keyword /hi. " Environment Liferay 6.2 Resolution This is intended behavior of Liferay, as, this is...
Cannot build a theme created with blade: Sass::SyntaxError: Invalid CSS after "...nput-margin-x: "
Issue When creating a theme in the latest Developer Studio, the build fails with Sass::SyntaxError: Invalid CSS after "...nput-margin-x: ": expected expression (e.g. 1px, bold), was "!default;" Environment Liferay DXP 7.1 Liferay DXP 7.2 Resolution Either use the latest Blade, IDE, or...
Asset Publisher Widget cannot display more than 200 items per page
Issue Configure an Asset Publisher to show a Number of Items to Display greater than 200, for example, 300. The Asset Publisher only shows 200 items. Environment Liferay DXP 7.0, 7.1, 7.2, 7.3, 7.4 Resolution Until Liferay DXP 7.3 Fix Pack 1: This is an expected limitation given by the...
How do I add a subject to workflow email notifications?
Issue When I set up a workflow for an asset (e.g.: Single Approver workflow for Web Content Articles) and I create a new Web Content Article, the approver receives an email notification but the email has no subject. Environment Liferay DXP 7.0+ Resolution In order to add a subject to the...
I can access the documents of a deactivated site unless permissions are revoked
Issue I have a deactivated Site If I try to access the Pages, I get the message: "This site is inactive. Please contact the administrator." At the same time, Documents and Assets can still be accessed and modified Users can use the document download links I expect that if I deactivate a...
When SAML is enabled, logging out from particular Site should stay at the respective site itself
Issue When SAML is enabled, logging out from "SITE A" is not redirecting/stays at the respective site's home page itself.  Environment Liferay DXP 7.1 SAML plugin Resolution The ideal scenario is authentication functions at the entire portal level and not at the site level due to which...
LDAP users are unable to log in
Issue Users who are present in LDAP are unable to perform login into Liferay and the below error was observed at the server console. ERROR [liferay/scheduler_dispatch-4][PortalLDAPImporterImpl:717] Unable to import user CN=abdulfar: null:null:{samaccountname=sAMAccountName: abdulfar}...

該当件数: 8,806 件中 5,081 - 5,100