Search Results

All Results 6923
ソート
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
KCS Article Quick Reference Guide
NOTE: This article is an INTERNAL article and is not visible to customers, currently. Please only link this article in internal comments, but not public comments. This is a quick reference guide for writing KCS articles on Help Center. Before You Submit! Title Issue Environment...
Troubleshooting Missing OpenID Connect Login Option and OIDC "not requested or was removed" Errors
Issue The OpenID Connect option doesn’t appear in the Sign In (login) portlet; or, starting OIDC returns an “OpenID Connect was not requested or was removed” error. Environment Liferay DXP Quarterly Release: 2024.Q1+ Resolution If the Open ID connect button is not displayed in the login...
Integrate Azure AD with Liferay DXP Using SAML
Integrating Liferay DXP with other Identity Providers (IdPs) is a recommended security best practice. By leveraging external authentication mechanisms, you can strengthen your system's security and simplify user management processes. This how to guides you through the basic steps needed...
How to Resolve JNDI Mail Session java.lang.NoClassDefFoundError: javax/mail/Authenticator Tomcat errors
Issue How can I resolve this exception observed during initialization of global JNDI resources during Liferay startup on Tomcat? org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.createMBeans Exception processing global JNDI Resources javax.naming.NamingException: Could not...
How can I add hyperlinks to an email template?
Issue I would like to replace a link, like [$PASSWORD_RESET_URL$], in an email template with hyperlink text, like ‘Click Here’. Environment Quarterly Releases Resolution You can configure a hyperlink through the HTML editing option. Navigate to Instance Settings > Email > Email Template...
Troubleshooting Unresponsiveness Caused by Batch Import Deadlocks
Issue After a period of activity, such as heavy content and object creation, the Liferay DXP instance becomes unresponsive. Symptoms include: Inability to accessible Liferay via browser or cURL requests, which eventually time out. Unresponsiveness after 2-3 hours of uptime, even if the...
How to View Previous Publication Dates for Web Content
Issue When editing a web content article that has a publication date set in the past, the Schedule Publication dialog appears with an empty date field. This behavior occurs for both newly created content scheduled for the past and for content that was created and published in a previous...
How to Access Nested Freemarker FieldSets in DXP 7.4+
Issue After upgrading to Liferay DXP 7.4+, FreeMarker templates appear to access fields within existing web content structures using different syntax than newly created web content structures. For example, older structures allow direct access to nested fields, while new structures...
ORA-01439, ORA-01440, ORA-22858, and ORA-22859 errors in the upgrade report after upgrading an Oracle database
Issue During a Liferay DXP upgrade when using an Oracle database, the upgrade completes with a success result, but the upgrade_report_diagnostics.txt file lists failed SQL statements such as these: Error: ORA-01439: column to be modified must be empty to change datatype Error: ORA-01440:...
How to Completely Delete a Portlet and Its Associated Data
Issue When a custom portlet is deprecated,it often remains in hundreds of pages across Liferay instances. Manually removing each instance and cleaning up the associated database entries is impractical. A method is needed to automate the complete removal of the portlet from all layouts...
How to delete site-scoped object entries on 2025.Q1.20 or 2025.Q1.21
Issue After creating site-scoped object entries, they cannot be deleted. Though company-scoped entries are unaffected, site-scoped entries are remaining even after: A success message being displayed in the Object Overview UI. A 204 response in the control panel. How can I delete these...
How to Resolve Jenkins Build "Content is not allowed in prolog" Errors
Issue When creating Liferay PaaS Jenkins builds, you may experience CI/CD pipeline build failures with errors relating to unresolved Gradle dependencies. For example: > Task :modules:your-module-name:compileJava FAILED [Fatal Error] dependency.pom:1:44: Content is not allowed in prolog....
How to add a certificate in Cacerts file in PaaS
Issue What is the best way to add a new certificate for the Cacerts file to trust the response of a consumed API in Liferay Cloud (PaaS)? Environment Liferay DXP 7.4+ Resolution To ensure your security settings survive a reboot, the best approach is to move the certificates out of...
Troubleshooting 'Portlet is temporarily unavailable' Errors Caused by JSESSIONID in URLs
Issue When navigating our site, a ;jsessionid parameter is intermittently appended to the page URL. When this happens, portlets on the page fail to render, displaying a Portlet is temporarily unavailable error. This issue occurs when the session handling mechanism falls back to URL-based...
Avoiding Empty File Uploads in Documents and Media
Issue When uploading a file in Documents and Media, a form refresh (e.g., by changing the Document Type or triggering a metadata validation error) causes the selected file to be cleared from the input field. Despite the file no longer being attached, the form can be submitted. This...
Getting Bad Request When Using API Filter Parameter on User Object Field
Issue When extending a system object, such as the User object, with a custom object field (e.g., customID), attempting to filter user accounts by this custom field using the headless API results in an error. The API call looks like this:...
Production Backups Not Visible in Disaster Recovery Environment After Configuration
Issue After following the documentation to set up Cross-Region Disaster Recovery in Liferay PaaS, the backups from the primary (production) environment are not visible in the secondary (disaster recovery) environment. The UI in the DR environment's Backup service does not show the tab or...
CKEditor Inserts Blank Paragraphs When Editing Articles Containing Audio or Video
Issue When a web content article containing an embedded audio or video file is created and then re-opened for editing, or when switching between WYSIWYG and source view, extra empty paragraph tags are inserted adjacent to the audio and video players. Environment Liferay DXP 2025.Q1+...
How To Upgrade JRXML Liferay Commerce Order Templates
Issue Liferay Commerce upgraded its internal reporting engine to JasperReports 7, utilizing a new XML schema with a Jackson-based parser that renders older Jasper 6 JRXML files incompatible. How can I upgrade custom Commerce order templates to the JasperReports 7 standard to make my...
Headless Object Relationship API Endpoint Returns 404 NOT_FOUND for Non-Admin Users
Issue When using a headless REST API endpoint to access an Organization related to a custom object, a 404 NOT_FOUND error returns for non-administrator users. This behavior occurs even if the user account's assigned role has explicit View permissions configured for both the custom object...

該当件数: 8,811 件中 8,181 - 8,200