Search Results

All Results 6932
ソート
Resource Type
Applicable Versions
Deployment Approach
Capability
Feature
パスワードリセット時、「秘密の質問」が設定されていないユーザーでもリセットが可能となる。
問題 パスワードリセット時、「秘密の質問」が設定されていないユーザーでも、「パスワードリセットリンクの送信」がクリック可能です。 環境 Quarterly Release 解決 この動作は、プロパティ設定で調整可能です。 以下のプロパティを設定する事で、「秘密の質問」が設定されていない場合、パスワードリセットができなくなります。 users.reminder.queries.required=true 追加情報 セキュリティに関する質問の答えを忘れてしまった場合、どうすればいいのでしょうか?, knowledgeArticleType: howTo, legacy:...
Webコンテンツの翻訳機能に表示されるフィールドの種類
問題 Webコンテンツの 右側三点ボタン> 翻訳 から、翻訳を追加可能です。 表示されないフィールドがあります。 環境 DXP 7.4 Quarterly Release 解決 HTML、数値、テキストフィールドのみが表示されます。 「ローカライズ可能」が有効になっているフィールドが表示されます。 追加情報 ウェブコンテンツの翻訳, knowledgeArticleType: reference, legacy: true, name: Webコンテンツの翻訳機能に表示されるフィールドの種類, showDisclaimerMessage: true,...
サイト全体のバックアップ/リストア方法
事象/ユースケース バックアップの取得方法とその際の注意点について リストア方法とその際の注意点について 解決策/提案 バックアップ対象 Liferayのディレクトリ アプリケーションサーバーのディレクトリ ドキュメントライブラリのディレクトリ データベース バックアップ手順 アプリケーションサーバを停止 $LIFERAY.HOME/ をバックアップ document_library/ をバックアップ(デフォルトから変更して、$LIFERAY.HOME/内にディレクトリが存在しない場合) $TOMCAT_HOME/...
Tomcat再起動後、初回アクセス時に表示が遅くなる要因
事象/ユースケース Tomcat再起動後、ページへの初回アクセス時に表示が遅い。 2回目以降のアクセスでは表示の遅延は発生しない。 解決策 / 提案 JSPは、初回呼び出し時にコンパイルされます。 そのため、初回アクセス時のコンパイルに時間がかかっているため、表示が遅くなっていることが考えられます。 事前コンパイルすることで、体感的な速度の向上が見込める可能性があります。 事前コンパイルにつきましては、プリコンパイラ(外部ツール)等の利用が選択肢になるかと存じます。...
"Liferay.Util.openWindow()"でモーダルウィンドウを作成した際、フォーカスがウィンドウの背面に残る。
問題 "Liferay.Util.openWindow()"を利用してモーダルウィンドウを作成した際、モーダルウィンドウ表示後もフォーカスが元の場所に残り、キーボード操作等でモーダルウィンドウ外を操作できる。 環境 DXP 7.4 Quarterly Release 解決 この問題は、Liferay.Util.openWindow の bodyContent プロパティに関連します。 モーダルウィンドウを作成したい場合は、Liferay.Util.openModal の使用が推奨されます。 Liferay.Util.openModal({ bodyHTML:...
Liferayへのアクセスが不安定になる。
問題 Liferayへのアクセスが一時的に不安定になりました。 以下のようなログがスローされます。 WARN [RuntimePageImpl-2][BasicResourcePool:678] com.mchange.v2.resourcepool.BasicResourcePool@72d9e3f5 -- an attempt to checkout a resource was interrupted, and the pool is still live: some other thread must have either interrupted the...
Liferay (Tomcat) のセッションタイムアウト時間の変更方法
Liferay (Tomcat) のセッションタイムアウト時間の変更方法 Resolution 設定手順 アプリケーションサーバーを停止 $TOMCAT_HOME/webapps/ROOT/WEB-INF/web.xmlを開き、以下のように変更して保存する ※初期値の30分から10分へ変更する例 <!-- 変更前 --> <session-timeout>30</session-timeout> <!-- 変更後 --> <session-timeout>10</session-timeout> アプリケーションサーバーを起動,...
Liferay PaaS services stuck in "Deployment in progress" status
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 注:Liferay は、Liferay Experience Could オファリングの名称を次のように変更しました。 Liferay SaaS(旧 LXC) と Liferay PaaS(旧 LXC-SM)となりました。 問題...
Permissions are requested for user Customer in Jenkins when Bitbucket is configured
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 注:Liferay は、Liferay Experience Could オファリングの名称を次のように変更しました。 Liferay SaaS(旧 LXC) と Liferay PaaS(旧 LXC-SM)となりました。 問題...
How to apply a custom hotfix without the ZIP file
Issue I need to apply a hotfix to a custom environment but have not downloaded the hotfix file previously. I need to install a SaaS hotfix in my local environment. Environment Liferay DXP 7.4 Quarterly Releases SaaS, PaaS, Self-Hosted. Resolution You can use the Patching Tool directly to...
Heap dump generation without a heap dump script
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 問題 お客様の環境でヒープ ダンプを生成するための のスクリプトの準備ができていない可能性がありますが、環境を乱すことなく現在の状態を取得したいと考え います。 Environment Liferay エクスペリエンス クラウド - SM 解決策 Liferay...
Large files (20MB+) on Git repository become corrupted when deploying to Cloud
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 問題 [IMPORTANT] .gitattributes を削除すると、さらに問題が発生する可能性があることをご承知おきください。 この記事は、このソリューションが以前に少なくとも一人の顧客と仕事をしたことがあることを考慮し、代わりに内部用に変更されました。...
Liferay SaaS incident contact roles on Analytics Cloud
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 注:この記事は内部の記事であり、現在、お客様にはご覧いただけません。 この記事へのリンクは社内のコメントでのみ行ってください。 注:Liferay は、Liferay Experience Could オファリングの名称を次のように変更しました。 Liferay SaaS(旧 LXC) と...
Load balancing for Liferay PaaS
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 注:Liferay は、Liferay Experience Could オファリングの名称を次のように変更しました。 Liferay SaaS(旧 LXC) と Liferay PaaS(旧 LXC-SM)となりました。 問題 Liferay...
[Internal] Custom Utility page doesn't work in Liferay SaaS
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 注:Liferay は、Liferay Experience Could オファリングの名称を次のように変更しました。 Liferay SaaS(旧 LXC) と Liferay PaaS(旧 LXC-SM)となりました。 注:この記事は内部の記事であり、現在、お客様にはご覧いただけません。...
Outgoing SMTP IP address for Liferay SaaS
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 注:Liferay は、Liferay Experience Could オファリングの名称を次のように変更しました。 Liferay SaaS(旧 LXC) と Liferay PaaS(旧 LXC-SM)となりました。 注:この記事は内部の記事であり、現在、お客様にはご覧いただけません。...
How to programmatically acquire a valid access token for a project's Liferay PaaS console?
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 問題 LXC の認証ドキュメント では、 「Cookie access_token からのトークンが取得され、 dxpcloud-authorization ヘッダーで使用される」と記載されています。 これには、ログに記録されたブラウザー ウィンドウから Cookie...
Integrate Jenkins (CI Service) with Azure DevOps
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 問題 LXCのContinuous IntegrationをAzure DevOpsに統合する方法 Environment LXC-SM(旧名称:DXPクラウド) 解決策 当社のLXC-SM(DXPクラウド)サービスでは、以下のOOTBインテグレーションに対応しています: GitHub...
shallow.lock': File exists errors
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 NOTE: この記事は INTERNAL の記事であり、現在お客様にはご覧いただけません。 この記事へのリンクは社内のコメントでのみ行ってください。 問題 一部のユーザーから、Jenkinsビルドのトリガー中に以下のエラーが発生したとの報告がある。 stderr: fatal: Unable...
How to resolve Jenkins error: "Oops! A problem occurred while processing the request"
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 問題 どのデプロイでもビルドが失敗し、Jenkins にアクセスしようとすると、次のエラー メッセージが表示されます: Oops! 要求 処理中に問題が発生しました。 Environment Liferay エクスペリエンス クラウド。 解決策 このエラーは、新しいバージョンの Jenkins...
How to setup S3 Store from Liferay 7.2 dxp-13
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 問題 ドキュメント (https://help.liferay.com/hc/en-us/articles/360018176151-Using-Amazon-Simple-Storage-Service) に従って S3...
Building and Deploying using the Liferay Cloud CLI
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 この記事は内部限定の記事です 問題 DXPクラウドCLIを使用したビルドとデプロイ 環境への配慮 DXP クラウドスタック v3 決議 CIサービス(Jenkins)もコマンドラインから lcp deploy が起動されたときにトリガーされます。...
Confirming a Site is Tracked by Analytics Cloud
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 問題 Analytics Cloud が Liferay DXP サイトに正しく接続されているかどうかわからない場合があります。 アクティビティが追跡されていない、またはサイトと Analytics Cloud...
Elasticsearch exception no mapping found para los campos spellCheckWord_es_ES o spellCheckWord_en_US
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 問題 Liferayの検索機能は問題なく動作していますが、Elasticsearchに関連する例外がログファイルに書き込まれることがあるようです: フィールドのマッピングが見つかりません [spellCheckWord_es_ES]...
Changing the name of an existing environment
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 問題 環境管理者としては、既存の環境の名前をもっと便利な方法で変更したい - ゼロから作り直す必要はありません。 環境への配慮 DXPクラウド 決議 新しい環境を作成する場合、基本的にはどのような名前でも設定できます - 環境管理者の要求に基づいて。...
To be able to access Liferay PaaS portal Database through DB client
ご覧のページは、お客様の利便性のために一部機械翻訳されています。また、ドキュメントは頻繁に更新が加えられており、翻訳は未完成の部分が含まれることをご了承ください。最新情報は都度公開されておりますため、必ず英語版をご参照ください。翻訳に問題がある場合は、こちらまでご連絡ください。 問題 ローカル クライアントを介して Liferay Experience Cloud Self-Managed (SM) データベースに接続する方法 Environment ライフレイ エクスペリエンス クラウド SM 解決策 ここに回避策があります。...
KCS Article Quick Reference Guide
NOTE: This article is an INTERNAL article and is not visible to customers, currently. Please only link this article in internal comments, but not public comments. This is a quick reference guide for writing KCS articles on Help Center. Before You Submit! Title Issue Environment...
Troubleshooting Missing OpenID Connect Login Option and OIDC "not requested or was removed" Errors
Issue The OpenID Connect option doesn’t appear in the Sign In (login) portlet; or, starting OIDC returns an “OpenID Connect was not requested or was removed” error. Environment Liferay DXP Quarterly Release: 2024.Q1+ Resolution If the Open ID connect button is not displayed in the login...
Integrate Azure AD with Liferay DXP Using SAML
Integrating Liferay DXP with other Identity Providers (IdPs) is a recommended security best practice. By leveraging external authentication mechanisms, you can strengthen your system's security and simplify user management processes. This how to guides you through the basic steps needed...
How to Resolve JNDI Mail Session java.lang.NoClassDefFoundError: javax/mail/Authenticator Tomcat errors
Issue How can I resolve this exception observed during initialization of global JNDI resources during Liferay startup on Tomcat? org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.createMBeans Exception processing global JNDI Resources javax.naming.NamingException: Could not...
How can I add hyperlinks to an email template?
Issue I would like to replace a link, like [$PASSWORD_RESET_URL$], in an email template with hyperlink text, like ‘Click Here’. Environment Quarterly Releases Resolution You can configure a hyperlink through the HTML editing option. Navigate to Instance Settings > Email > Email Template...
Troubleshooting Unresponsiveness Caused by Batch Import Deadlocks
Issue After a period of activity, such as heavy content and object creation, the Liferay DXP instance becomes unresponsive. Symptoms include: Inability to accessible Liferay via browser or cURL requests, which eventually time out. Unresponsiveness after 2-3 hours of uptime, even if the...
How to View Previous Publication Dates for Web Content
Issue When editing a web content article that has a publication date set in the past, the Schedule Publication dialog appears with an empty date field. This behavior occurs for both newly created content scheduled for the past and for content that was created and published in a previous...
How to Access Nested Freemarker FieldSets in DXP 7.4+
Issue After upgrading to Liferay DXP 7.4+, FreeMarker templates appear to access fields within existing web content structures using different syntax than newly created web content structures. For example, older structures allow direct access to nested fields, while new structures...
ORA-01439, ORA-01440, ORA-22858, and ORA-22859 errors in the upgrade report after upgrading an Oracle database
Issue During a Liferay DXP upgrade when using an Oracle database, the upgrade completes with a success result, but the upgrade_report_diagnostics.txt file lists failed SQL statements such as these: Error: ORA-01439: column to be modified must be empty to change datatype Error: ORA-01440:...
How to Completely Delete a Portlet and Its Associated Data
Issue When a custom portlet is deprecated,it often remains in hundreds of pages across Liferay instances. Manually removing each instance and cleaning up the associated database entries is impractical. A method is needed to automate the complete removal of the portlet from all layouts...
How to delete site-scoped object entries on 2025.Q1.20 or 2025.Q1.21
Issue After creating site-scoped object entries, they cannot be deleted. Though company-scoped entries are unaffected, site-scoped entries are remaining even after: A success message being displayed in the Object Overview UI. A 204 response in the control panel. How can I delete these...
How to Resolve Jenkins Build "Content is not allowed in prolog" Errors
Issue When creating Liferay PaaS Jenkins builds, you may experience CI/CD pipeline build failures with errors relating to unresolved Gradle dependencies. For example: > Task :modules:your-module-name:compileJava FAILED [Fatal Error] dependency.pom:1:44: Content is not allowed in prolog....
How to add a certificate in Cacerts file in PaaS
Issue What is the best way to add a new certificate for the Cacerts file to trust the response of a consumed API in Liferay Cloud (PaaS)? Environment Liferay DXP 7.4+ Resolution To ensure your security settings survive a reboot, the best approach is to move the certificates out of...
Troubleshooting 'Portlet is temporarily unavailable' Errors Caused by JSESSIONID in URLs
Issue When navigating our site, a ;jsessionid parameter is intermittently appended to the page URL. When this happens, portlets on the page fail to render, displaying a Portlet is temporarily unavailable error. This issue occurs when the session handling mechanism falls back to URL-based...

該当件数: 8,839 件中 8,201 - 8,240