Documentation

ストラクチャーの作成

以下の手順に従って、ストラクチャーを作成します。

  1. プロダクトメニューを開き、サイトメニューの見出し → [コンテンツ & データ] → [Webコンテンツ] に移動します。

  2. ストラクチャー] タブを選択します。

  3. 追加ボタンAdd Structure)をクリックして、新しいストラクチャーを作成します。

  4. 新しいストラクチャーのタイトルを入力します。

  5. 使用可能なフィールドをストラクチャーにドラッグアンドドロップし、それらの設定を構成してストラクチャーを作成します。

    ちなみに

    ストラクチャーを編集または作成したとき、デフォルトでViewタブが選択されています。 ソースタブに切り替えて、ストラクチャーの生のXMLを表示し、直接変更することができます。

  6. 必要に応じて、ストラクチャーの 説明 を追加します。

  7. Save] をクリックします。

新しいストラクチャーを作成するときに、パレットからフィールドをドラッグしてキャンバスにドロップできます。

警告

インポート / エクスポート操作により、同じstructureKeyを持つグローバルストラクチャーとサイトスコープのストラクチャーの両方を持つことができます。 これが発生した場合、サイトスコープのストラクチャーが優先され、そのサイトからグローバルストラクチャーにアクセスできなくなります。

ちなみに

Webコンテンツとストラクチャーの追加設定オプション(例:カスタムストラクチャーキーの設定を有効にする)については、[システム設定]→ [コンテンツとデータ]→ [Webコンテンツ]→ [管理]をご覧ください。

ストラクチャー項目

次のフィールドをストラクチャーに配置できます。

ブール値: true (オン)または false (オフ)のいずれかを格納するチェックボックス。 たとえば、このフィールドを使用して、ストラクチャーのコンテンツの表示ルールを設定できます。

色: カラーピッカー

日付: 日付ピッカーを表示するフォーマット済みのテキストフィールド。 日付形式は、現在のロケールによって異なります。

小数: 小数を受け付ける入力

ドキュメントとメディア: ドキュメントとメディアライブラリまたはコンピューターからのファイルを含めるためのファイルセレクター

位置情報: 設定された場所を表示する地図。 位置情報は、現在の場所と別の場所への道順の両方を提供します。

HTML: コンテンツを書き込むためのより多くのフォーマットオプションを提供するWYSIWYGエディター

画像: ドキュメントとメディアライブラリまたはコンピューターからの画像を含めるための画像セレクター

注釈

コンピューターから画像をアップロードした場合、その画像はその特定の記事でしか利用できません。

整数: 整数を受け入れる入力

ページへのリンク: 同じサイト内の別のページへのリンクを含めるためのセレクター

Number: 任意のタイプの数値を受け入れる入力

ラジオ: ラジオボタンを使用して選択するオプションのリスト。 このフィールドでは、1つの選択のみが許可されます。

選択: コンボボックスを使用して選択するオプションの選択。 このフィールドでは、複数選択できます。

セパレーター: フィールドを区切る水平線

テキスト: タイトルや見出しなどの短いエントリのテキスト入力

テキストボックス: コンテンツの本文などの長いエントリのテキスト入力

Webコンテンツ: 既存のWebコンテンツ記事を含めるためのセレクター

ストラクチャー項目の設定と編集の詳細は、Editing and Configuring Structure Fieldsを参照してください。

ストラクチャーを翻訳する

ストラクチャーの作成中または後で、ストラクチャーの翻訳を追加することができます。

Webコンテンツストラクチャーの翻訳を管理します。

  1. ストラクチャーの追加または編集画面から、ロケール(例:en-us)をクリックして言語選択を開き、 [Manage Translations] を選択してください。

  2. [Manage Translations]モーダルで 追加ボタン(Add)をクリックし、言語を選択します。

  3. Done] をクリックします。

  4. デフォルトロケールをもう一度クリックし、新しいロケールを選択して翻訳を開始します。

  5. ストラクチャーのテキストを好きなだけ翻訳し、 [保存] をクリックします。

翻訳を削除するには、Manage Translationsモーダルに戻り、ゴミ箱アイコン Trashをクリックします。

翻訳を編集するには、言語選択で翻訳を選択し、変更を加えてから、 [保存] をクリックします。